Suzuki ATV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello,

I a newbie, hello everyone! I recently purchased this quad and noticed the cooling fan is not coming on. I checked power to it and it spins. I replaced the switch in the rad as it was cheap. Still nothing. I hear there is a fuse and have looked high and low. Where the heck is this fuse, as I understand there is one, but I can’t find it.
Also noticed a toggle switch on the left side of the sterring column that lights up when turned on. Does anyone know if this is stock or a add on? What does it do?
 

·
Registered
Joined
·
2 Posts
Hello,

I a newbie, hello everyone! I recently purchased this quad and noticed the cooling fan is not coming on. I checked power to it and it spins. I replaced the switch in the rad as it was cheap. Still nothing. I hear there is a fuse and have looked high and low. Where the heck is this fuse, as I understand there is one, but I can’t find it.
Also noticed a toggle switch on the left side of the sterring column that lights up when turned on. Does anyone know if this is stock or a add on? What does it do?
I know this is an older thread but did you ever figure out the answer to your question? I have a 2005 and I can not find a fuse either. They mention it briefy in the service manual as a 10 amp but it is not on the wiring diagram
 

·
Super Moderator
2020 KingQuad 750
Joined
·
357 Posts
Sorry, cant help with this specific model, but, for what it's worth, on the newer 2019's and up, 500's and 750's, the cooling fan has it's own fuse located in the main fuse box with the headlight fuses, fuel pump and ignition fuses ... it is the O/R wire going in and it is a 15 amp. My knowledge of reading electrical diagrams is the same as trying to figure out nuclear fission so take it on a dime.
 
1 - 3 of 3 Posts
Top