Suzuki ATV Forum banner
121 - 135 of 135 Posts

·
Registered
Joined
·
5 Posts
I let my Ozark sit for a year in ON position and now starts but can't run 5 feet off choke. Replaced plug but same problem no power off choke. Oil looks not fuel contamination but res PRI peacock might be problem ? R the peacock bolts 10mm ? It just drop down and off right ?

Thanks
Patrick
 

·
Registered
Joined
·
5 Posts
20014
20015
20016
Auto part
Auto part Vehicle Engine Wheel Family car
Auto part Vehicle Car

I let my Ozark sit for a year in ON position and now starts but can't run 5 feet off choke. Replaced plug but same problem no power off choke. Oil looks not fuel contamination but res PRI peacock might be problem ? R the peacock bolts 10mm ? It just drop down and off right ?

Thanks
Patrick
Update; I'm draining fuel via the PRI mode as nothing flows using RES or ON. Why is that happening ?

What hose is pictured coming off carb side just behind the chock chamber ? The other end is free floating with three small vents hole showing at end of hose.

Many thanks, I've never worked on ATV other than plug and oil changes.

Patrick
 

·
Registered
Joined
·
14 Posts
question

new member and am not sure if this is the place to ask but I have a 2003 eiger 400 quad runner auto. I have three hoses that seem to go nowhere one is clear and comes off of the fan and runs back by the carb but it is not hooked to anything and two black ones under the seat one is 1/2 inch and the other looks to be 1/4 inch. Can anyone tell me where they are suppose to connect or if they are suppose to connect to anything, Thanks
They do not hook up to anything. They are air tubes. Had me confused for awhile also. :)
 

·
Registered
LTF4WD 1989 LTA500F 2001
Joined
·
14 Posts
A Great post. My 2 cents are I have a Quadmaster ON, PRI, RES. The quad had gas in the crank case even though it was in ON position (Off when engine not running...or meant to be). I took apart the petcock and found damage to the smiley face rubber gasket. I turned it around and hoped it would seal.... nope! So waiting for a petcock rebuild kit from fortnine in Canada and will also add an in line on/off valve to make 100% sure.
 

·
Registered
Joined
·
2,108 Posts
Twosuzukiatv
The gas was entering your crank case via the vacuum hose with the defective diaphragm .
 

·
Super Moderator
Joined
·
1,465 Posts
Having same problem got new pitcock from Amazon it was 13 bucks. Would anyone know how to tell the difference between a 250 and a 300 king quad?
Welcome to the forum.

Just to be clear, you want to know if your machine is a 250, or a 300?

If that is the case, post your VIN and we can help
 

·
Administrator
Joined
·
9,802 Posts
The Vin# is typically located on the left rear downtube. It’ll be a small welded that’ll be facing the inner left rear tire. I have a image on on my PC, but unfortunately not on my phone. If I remember I’ll try and go on later and a post it.
 
121 - 135 of 135 Posts
Top