Suzuki ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 99 Suzuki LT F250 and am having some issues with my transmission slipping. I put synthetic oil in last year in hope of extending its life, but this year I noticed the transmission slipping when I start out and if I give it a lot of throttle. It seems to be worse in high range. I mainly use it in low range to run around with the kids and pull my cart. I just switched back to regular oil which one of the guys at the dealer suggested but it still slips just seems to be a little better. Anybody have a suggestion.
 

·
Registered
Joined
·
137 Posts
Do you have the correct oil? ATV specific?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Yes, I did use ATV oil after the synthetic. It is Honda oil but it is the right weight and viscosity. The guy at the dealer gave it to me knowing what type of ATV I had.
 

·
Registered
Joined
·
137 Posts
Weird....Idk then.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Not sure if I should try changing it again just to refresh it? I really don't know what to do at this point. I would love to buy something else but I baught a dual sport motorcycle last year.
 

·
Registered
Joined
·
137 Posts
Was the synthetic oil ATV specific oil? Your clutch plates have gone bad probably.
 

·
Registered
Joined
·
4 Posts
Most ATV's have a clutch adjustment somewhere on them. If you have a manual, just it out and it should tell you how to fix the problems and explain how to adjust the clutch on it.
 
1 - 7 of 7 Posts
Top