Suzuki ATV Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Good Evening! Love this forum! I have been lingering for a month or so and learning so much!! I am trying to figure out what I need to do with my new to me ATV i picked up for some plowing at the resort. It starts right up without issue after I replaced the 4 almost 5 year old batter and thats great! I feel like the power is low on this machine compared to our super old polaris 500. I cant get it to go more than 15 MPH. I have no weird stumbles with the machine, it revs out fine. I did purchase a new belt but im waiting for it in the mail still. I just dont know what else it could be? When I rev it up some I hear noise from the belt case so i'm pretty sure it has never been done. yikes! Its a trooper tho!
Water Road surface Building Asphalt Window
 

· Registered
Joined
·
9 Posts
Discussion Starter · #2 ·
Also, i'm not into speed but i'm thinking its a sign of lack of power getting to the wheels even for plowing with it being so slow. I dont know how to tell if the belt is the problem. This is in 4x4 mode in High Gear. Plowing always in Low.
Tire Wheel Snow Vehicle Automotive tire
 

· Super Moderator
Joined
·
1,576 Posts
Welcome to the forum.

You answered a question I was going to ask when you said “This is in 4x4 mode in High gear”. Low gear has speed limitations.

If your belt was the restriction, I would think it would be screaming when under load and plowing, or when you have maxed out your speed in high gear.

Nevertheless, you said the belt is on the way, so let’s see what happens when it arrives.


I would also check the normal things like air and fuel filters, spark plug, fresh fuel, grounds…

Was it sitting for a long time?

Also, i'm not into speed but i'm thinking its a sign of lack of power getting to the wheels even for plowing with it being so slow. I dont know how to tell if the belt is the problem. This is in 4x4 mode in High Gear. Plowing always in Low. View attachment 23022
 

· Administrator
Joined
·
9,879 Posts
Welcome to the Forum. Glad to have you aboard.
 
  • Like
Reactions: Upnorthbros

· Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Welcome to the forum.

You answered a question I was going to ask when you said “This is in 4x4 mode in High gear”. Low gear has speed limitations.

If your belt was the restriction, I would think it would be screaming when under load and plowing, or when you have maxed out your speed in high gear.

Nevertheless, you said the belt is on the way, so let’s see what happens when it arrives.


I would also check the normal things like air and fuel filters, spark plug, fresh fuel, grounds…

Was it sitting for a long time?
Thank you so much! It has not been sitting.I bought from a friend who used it on a farm. He kept up on all the oil changes and fluids but his wife wanted a side by side and they purchased one in early Jan.
 

· Super Moderator
Joined
·
1,576 Posts
Thank you so much! It has not been sitting.I bought from a friend who used it on a farm. He kept up on all the oil changes and fluids but his wife wanted a side by side and they purchased one in early Jan.
This has a manual choke, correct?
 
1 - 12 of 12 Posts
Top