Suzuki ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
189 Posts
Discussion Starter #1 (Edited)
since the change I received a new password and couldn't get in w/ it after repeated tries over several days. Requested a new one this AM and got in to change the new one to something more easily remembered and after twice trying to change it, it tells me the password I used doesn't match the one I logged in with. Yes, I dotted all the i's and crossed all the t's 'til all the red "X's" were gone. HELP PLEASE!! Please reply by E-mail in case I can't get back in.
Mike
 

·
Super Moderator
Joined
·
7,626 Posts
First off, we can't send you an email when you don't have a personal email address in your contact information. So with that said, I'm going to write a reply here and hope you see it.

As for your problem, I had this very issue. What I was doing was missing a step. When your at the page where you need to enter your new password, look closely above the (Enter Your New Password Box). You'll note there's another box above that one where you need to put in your old password, (Temporary Password). Once you've entered the temp password in that box create your new password with all the appropriate credentials and re-confirm it in the following box and you should be good to go.
 

·
Registered
Joined
·
184 Posts
I have done as you instructed above ajl719 but the save tab will not activate for me to save my new password only the reset fields it activated. How can I correct this ?


Tony
 

·
Premium Member
Joined
·
67 Posts
The save button should become available as soon your new password meets the criteria. Are you sure all X's are checkmarks when inputting a new password?

Which browser and OS are you on?

Thanks,
- JB
 
1 - 4 of 4 Posts
Top