Suzuki ATV Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited by Moderator)
Hi guys, new to forum, have an older 250z quadsport, owned since new. Been in storage for probably 10 yrs. was stored dry, but don’t think it was running when put away. Son had it. Put battery in it and rebuilt carb, wont start. Has compression and spark, valves have clearance. Will start and run on brake kleen. Assumed carb was bad and replace with cheap Chinese replacement. Same thing. Checked for vacuum leak at carb boot, no leak. Its got me stumped. Would say it skipped cam timeing except it runs on brake kleen. Compression cold was 160 lbs. ordering manual. Any help will be appreciated.
 

·
Registered
Joined
·
1,835 Posts
Is gas filling the carb and did you drain and refill the tank with new gas?
 

·
Super Moderator
Joined
·
7,700 Posts
Does your model Quadsport have a fuel pump..? If so, is it sending fuel to the carb..? Pull the line from the fuel pump that runs to the carb and crank the engine to see if fuel is coming out. Can also try running the your quad with the fuel petcock set in Pri (Prime, to see if thad gets it to run. Just make sure you set it to back to the original position after your done your testing.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
No fuel pump, vacuum petcock. Petcock in prime fuel running thru fuel line, float bowl has fuel. Only fires on brake kleen. This one has me stumped!
 

·
Registered
Joined
·
5 Posts
Stupid question but is the choke working right? There's really not much more it could be. As long as the carb is clean. You said you replaced it with a cheap one. That's a big problem in it self. I'm willing to bet the stock one would work much better. Maybe just take the jets out of the cheap one and anything else you might need off of it and put it on the stock carb. As you're trying to start it hold your hand over the air intake and see if you start getting gas in the motor.
 

·
Registered
Joined
·
13 Posts
It's amazing that it fires on brake clean especially since it's non flammable. Start with the basics spark, fuel, timing. If it's got spark, timing is gear driven, it must be fuel. Flush out the tank, lines & fuel pump then clean the carb with a strong carb cleaner like Berrymans and blow it out with compressed air. You should be back in business.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
What ever it was, i used a large saline syringe, to force gas into carb, and it ran. If anyone cares, the Chinese carbs on ebay will kinda work. There a pita. Funny they can’t copy a metric carb. The carb itself, is to big in diameter, so the intake needs to be opened up alot. The air-cleaner side barely fits, and not well, the steal throttle cable tube, needs to be replaced with the original, and it requires heating to remove it. It runs a little fat at idle to 3/4 throttle, and real fat at full throttle, and will surge. But if your carb is beyond repair, it will run. I ordered a new intake and will try my stock carb again. Thanks for all the imput.
Steve
 
1 - 9 of 9 Posts
Top