Suzuki ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi I’ve recently picked up an lt50 with a few problems

Guy recently replaced carb for a new cheapy one

I expect these are not usually great? I’ve found it will not idle without leaving the choke on very slightly.. guy said when it’s fully warmed up he could switch it off but that has not been the case

Also the quad is creeping forward on idle.. I don’t think Revs are to high and throttle cable doesn’t seem to be giving it throttle

Any ideals?

Thanks
 

·
Registered
Joined
·
1 Posts
I have an 8 year old LT50 and it will not stand still with the engine running, it always tries to move forward. Even when you pull the brake lever to start it the back wheels try to turn. shareit vidmate

Does anyone know what the problem could be and how to fix it?
 

·
Super Moderator
Joined
·
707 Posts
I have an 8 year old LT50 and it will not stand still with the engine running, it always tries to move forward. Even when you pull the brake lever to start it the back wheels try to turn. shareit vidmate

Does anyone know what the problem could be and how to fix it?
Welcome to the forum. The thread you replied to here is from 2019. Please refrain from posting to threads that have been inactive for over a year. It’s in the forum rules, which you should review.

Also, I am not sure if you were trying to post a video. I see a link to shareitvidmate ?

Feel free to start your own thread on this subject. I’m sure someone will attempt to assist you. If you want to post a video, you can upload it to YouTube and put a link to it in your thread. If you need help, just ask.

Again, welcome.
 
1 - 4 of 4 Posts
Top