Suzuki ATV Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
Has anyone tried the Velocity Devices (VDI) Copperhead unit for the King Quad 750? I have read some interesting reviews and finally got mine the other day. Installation was easy and the unit looks well made. It idles well and starts easily. I am looking forward to some bottom end power gains.

I will be doing some testing mid November and intend to post a review .
 

·
Registered
Joined
·
73 Posts
Discussion Starter #3 (Edited)
I just installed the Copperhead and did some preliminary testing. My initial reactions are all very positive . My King Quad starts easily, idles better than with the stock ECU and definetely has more low end power. Unfortunately, I also changed my tires at the same time. Although I kept the exact same size, the replacement STI Black Diamonds are much taller. The increased size is changing my effective gear ratio. Even with the taller tires and my limited testing, I can still feel the increased performance from the VDI unit. I did a quick blip of the throttle and the front end lifted with ease. No pulling on the handlebars at all and no throwing my weight backward.

I should add that my King Quad is fully dressed. I have a front and back box and a winch. My front box has two small coolers and the rear box is packed with gear. I also have a full three gallon gas can onboard. I would estimate that with the gear plus my 215 pounds, the total weight is around 1020#.

I wonder what the Copperhead would do on a stripped down machine with a lighter driver?
 

Attachments

·
Registered
Joined
·
9 Posts
Everything still going well with the VDI?
What year is your KQ750? I ask because I've read mixed reviews when it comes to the newer machines (2014+...). There's even a YouTube video where the guy plugs in the VDI and the machine stutters and dies. He then puts the stock one back in and the machine runs normally. Additionally there appears to be zero customer support on this product from the company... specifically some guy named Lyle. Lots of red flags... be nice to hear that the bugs have been worked out. $500 is steep for something that doesn't work and has no support.
 

·
Registered
Joined
·
97 Posts
I bought an 05 KQ that came with a vdi. It was a little hard starting and would stall quite often, I got a stock ecm from ebay and machine started faster but also stalled. I found a bad ground wire that caused the stalling but I am happy with the stock ecm.
 

·
Registered
Joined
·
834 Posts
I have also been wondering if these vdi units were any good since I will be looking for some plug in horse power at some point in the near future. I just do not wanna drop 500.00 on something that is total garbage and that will be sitting on a shelf.
 

·
Registered
Joined
·
2 Posts
Our customer support is second to none. That particular customer had an issue with his machine. Instead of contacting us for support, he decided to trash us on web forums, as well as posting videos of his issues.

Backstory:
He purchased one of the first units we shipped in 2014. We had such high demand that we were backordered, and were unable to ship his immediately. He proceeded to complain to us because he felt he deserved to have one of the first units ever shipped on the 2014 King Quad, and getting a shipment from the second build lot wasn't acceptable.

After the issues he experienced, we determined there was something wrong with his ECU he purchased, but he refused to mail to back for a warranty replacement. After 14 months he went back to internet forums to complain about it not working again, apparently expecting us "to make it right".

Unfortunately, we cannot help people that cannot help themselves. If you have issues with our product, call or email us. You will get a response with 24 hours, most business days.

Lyle
 

·
Registered
Joined
·
2 Posts
For the record, we have been selling replacement ECU's since 2004. The King Quad line is our top seller (5 to 1 over any other brand).

On the Kings, you will get a lot better throttle response, cooler running engine, as well as fuel savings when trail riding. Our test machine was a 2006 AC700EFI (with the KQ700 engine).

Adding our ECU transformed that machine 100%:
1) Fuel consumption was reduced approximately 25% when trail riding (being nice on the throttle, you will burn more fuel if you continuous jab or run WOT).
2) Cooler running. Previously, the fan would come on 5 minutes from camp, and stay on the entire day. With our unit, fan could seldom turn on, and then turn off as expected. It now longer did that stumble/cough/stall after stopping for a break due to an over-hot engine.
3) More part throttle power. I could ride into a water hole rack deep, and feather the throttle through in high range with no issues.
4) More power throughout the power band.


In 2014 Suzuki did a lot of engine changes to improve efficiencies. The multi-hole injector gives better part throttle power on that engine (something I had been saying for years on the web forums). They did re-cam the engine for less valve overlap (and less emissions) so the power band isn't as great as the 2013 and earlier engines. Our ECU still gives great power on them though.

Lyle
 

·
Registered
Joined
·
834 Posts
Our customer support is second to none. That particular customer had an issue with his machine. Instead of contacting us for support, he decided to trash us on web forums, as well as posting videos of his issues.

Backstory:
He purchased one of the first units we shipped in 2014. We had such high demand that we were backordered, and were unable to ship his immediately. He proceeded to complain to us because he felt he deserved to have one of the first units ever shipped on the 2014 King Quad, and getting a shipment from the second build lot wasn't acceptable.

After the issues he experienced, we determined there was something wrong with his ECU he purchased, but he refused to mail to back for a warranty replacement. After 14 months he went back to internet forums to complain about it not working again, apparently expecting us "to make it right".

Unfortunately, we cannot help people that cannot help themselves. If you have issues with our product, call or email us. You will get a response with 24 hours, most business days.

Lyle


So his was a 1st gen. VDI unit ? If that is the case has the VDI unit been improved at all ? As I said before, I do not want to spend big money to sit on a shelf or in a garbage can. I ride in mud and water so is that covered under warrenty ? I just don't want to spend 400.00 to 500.00 on a unit that is not up to the same challenges as the rest of the wheeler.

Gordon
 

·
Registered
Joined
·
9 Posts
Our customer support is second to none. That particular customer had an issue with his machine. Instead of contacting us for support, he decided to trash us on web forums, as well as posting videos of his issues.

Backstory:
He purchased one of the first units we shipped in 2014. We had such high demand that we were backordered, and were unable to ship his immediately. He proceeded to complain to us because he felt he deserved to have one of the first units ever shipped on the 2014 King Quad, and getting a shipment from the second build lot wasn't acceptable.

After the issues he experienced, we determined there was something wrong with his ECU he purchased, but he refused to mail to back for a warranty replacement. After 14 months he went back to internet forums to complain about it not working again, apparently expecting us "to make it right".

Unfortunately, we cannot help people that cannot help themselves. If you have issues with our product, call or email us. You will get a response with 24 hours, most business days.

Lyle
I'm in the same boat as Gordon. $500 is a lot for a paperweight. I would like to know what has been changed since the guy in the videos had his problem.

What do you think was wrong with his VDI??? How is it remedied???

Also, I've read several other reports about the VDI being current sensitive...too low or high and the unit stumbles. Has this been resolved? Stock ecu has no such issues.

Thanks for the reply, Lyle.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #13
Everything still going well with the VDI?
What year is your KQ750? I ask because I've read mixed reviews when it comes to the newer machines (2014+...). There's even a YouTube video where the guy plugs in the VDI and the machine stutters and dies. He then puts the stock one back in and the machine runs normally. Additionally there appears to be zero customer support on this product from the company... specifically some guy named Lyle. Lots of red flags... be nice to hear that the bugs have been worked out. $500 is steep for something that doesn't work and has no support.

Everything is going GREAT with the VDI. My King Quad is a 2009 750. It was pretty much a beast before the VDI and even more so now. I wasn't able to get away and do the trail testing that I wanted to perform in November. I was, however, able to do some local riding here on Long Island during a blizzard in January. I was very impressed with the VDI in terms of starting , drive ability and performance. Despite the harsh weather conditions, the King Quad ran admirably . I can definitely feel the increased performance. No doubt about it, the VDI does add power across the operating range.

As far as Lyle goes, I corresponded with him directly when I ordered my VDI. He strikes me as knowledgeable, sincere and to be concerned about his product and his customers. I got the same information from other riders that purchased his products. I'm glad he has already weighed in on this thread.

Not to long ago I was asking others how they felt about the product. Now I will say to the skeptics, it's well worth the money. Go for it!
 

·
Registered
Joined
·
6 Posts
I just bought a 2018 king quad 750 and I've been looking for something to add some power... Not because it needs it at all... But because, well, POWER!! LOL
It kinda sounds like this would be made more fore the pre-2014 models from what I read from Lyles response... Or at least not gonna be worth the 500 as much as it would be for those models.
Does anyone have any experience with this on the newer models like mine that could weigh in on it?
 

·
Registered
Joined
·
11 Posts
Has anyone tried the VDI on a KQ450? I have an ‘07.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
12 Posts
From my own experience, the copperhead ECU made my '05 KQ 700 more of a beast than it was before. I highly recommend it. I guess they don't work well on multi-cylinder engines, but for mine it was a great increase in power (especially low-end) and idled better than stock.
 

·
Registered
Joined
·
834 Posts
I took the plunge and bought a vdi copperhead, it just arrived today but I hope to install its either sometime this week or this coming weekend.
 

·
Registered
Joined
·
10 Posts
I've been wanting to save up a little money on the side for one of these for my 2016 KingQuad 750AXI and now that i've seen your review I feel more confident in choosing to buy one. Thanks!
 

·
Registered
Joined
·
834 Posts
I've heard anything 2014 and newer that they are not a huge help and that they do very little but I have an 08 so I'm not sure of its true or not.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #20
I took the plunge and bought a vdi copperhead, it just arrived today but I hope to install its either sometime this week or this coming weekend.
I hope yours works out as well as mine. I am very impressed ! My son outgrew his 250 Ozark, so I gave him my Vinson and bought the KQ750 for myself. There is about a 100# difference between my son and I. He is a lightweight at 115#. I'm around 210. I carry all the gear in two boxes on the King. His 500 Vinson could just about keep up with me on the King before I installed the VDI. Now, not so much. It has definitely improved the power output. The throttle feels "crisper " and the engine is more responsive. Also, I previously had stalling issues when the engine was cold, if I tried to take the King off the trailer before it warmed up for a minute , or two. Not any more. I turn the key and go.
 
1 - 20 of 34 Posts
Top