Suzuki ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I am new to ATV's so any help is appreciated. I was riding last night at high speeds & the engine stalled. Just like it ran out of gas. The engine will turn over but only fires intermittently. I towed it home. Checked the gas & found it low. Added gas. Spun the engine & it fired up & idled a couple of minutes then died. Fired back up & sputtered & stalled. After looking at the machine, i found a vent hose from the carb. It leaks gas when the fuel valve is turned to prime. When the valve is turned to run position, gas only comes out when the engine is spun. Do i have a diaphragm leaking somewhere?
 

·
Registered
Joined
·
18 Posts
Check your oil in the crankcase. Sometimes the petcock fails and instead of allowing fuel to enter the engine under vacuum it allows it even under engine off conditions. It could be your engine is starving for gas or flooding, either one. If the petcock fails and dumps gas in off position, and you drive it you will ruin your engine.
 

·
Super Moderator
Joined
·
7,477 Posts
Prime is gravity fed. Meaning fuel will flow regardless of if the engine is running or not. In the On position fuel will flow only when the engine is being cranked or running. This is because fuel is drawn through vacuum. Check all your hoses over and make sure they are connected in the right place and that none have become disconnected.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Thanks for the info guys. The pet cock is working properly. I believe either the carb is overfilling & dumping out of the hose or the pump diaphragm is leaking. My engine oil doesn't appear to have any gas in it.
 

·
Super Moderator
Joined
·
7,477 Posts
If the carb is overflowing. The float might be stuck or out of spec.


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top