Suzuki ATV Forum banner
1 - 8 of 8 Posts

·
Registered
2019 LT-A400F
Joined
·
41 Posts
Discussion Starter · #1 ·
Just started hearing this rattle like noise last two times I've taken out my atv. I've checked for any loose parts and can't seem to find anything. Brake rotor is tight, caliper is tight. It DOES have that annoying Suzuki Squeak but its completely different.

I've even tried to wrap some electrical tape around the spring that protects the brake hose where it rides near the hard brake line that bolts to the caliper with no joy.

it is the model listed in my signature

Thanks for any help!
D
 

·
Registered
Joined
·
2 Posts
Just started hearing this rattle like noise last two times I've taken out my atv. I've checked for any loose parts and can't seem to find anything. Brake rotor is tight, caliper is tight. It DOES have that annoying Suzuki Squeak but its completely different.

I've even tried to wrap some electrical tape around the spring that protects the brake hose where it rides near the hard brake line that bolts to the caliper with no joy.

it is the model listed in my signature

Thanks for any help!
D
I have the same issue on my 2020 750 king quad. I've owned several cvt quads and never had one this noisy. Going to the dealer tommorow.
 

·
Registered
Joined
·
2 Posts
I have the same issue on my 2020 750 king quad. I've owned several cvt quads and never had one this noisy. Going to the dealer tommorow.
Went to the dealer yesterday. They contacted Suzuki. They registered my concern with them. The warranty only covers failures or I can have a dealer dig into it but if they do not find anything it's on my dime. They supposedly have not received any complaints about this so they aren't doing anything about it at this time. I would definitely register your concerns with Suzuki
 

·
Registered
Joined
·
97 Posts
I would put it on jack stands on four corners and 2 and 4 wheel drive at the speed that gives the sound. I understand that won't duplicate the road but you might find it.
 

·
Registered
2019 LT-A400F
Joined
·
41 Posts
Discussion Starter · #5 ·
well I am blind lol

one of those dang plastic trim fasteners was not fully engaged into the inner plastic fender. Making sure it was fully seated and engaged did the trick.

BUT I see myself replacing these as they fail with wide head fasteners and locking nuts.
 

·
Registered
Joined
·
97 Posts
Look for those push pin fasteners on Amazon maybe ebay. I think I remember that the Honda were less money and better, Some one will chime in and give the best ones to use. I only use screws and lock nuts on the out side of all corners as they will be the first to popout.
 

·
Registered
2019 LT-A400F
Joined
·
41 Posts
Discussion Starter · #7 ·
so the issue did NOT go away. Angry noises and foul words from Darrell occurred.

took to the local dealer since it was under warranty and found out that it was....the exhaust heat shield breaking a mounting tab.

7-10 days to get the new part...wow...but its covered and will be fixed so woohoo!

D
 

·
Super Moderator
Joined
·
8,801 Posts
Glad your issue was finally solved. And it sounds like it’s a relatively easy fix as well.
 
  • Like
Reactions: db_tanker
1 - 8 of 8 Posts
Top