Suzuki ATV Forum banner
21 - 29 of 29 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter · #23 ·
Yea but my feeler gauges have disappeared and I don’t trust myself enough to not make it worse if there is anything out of whack on it
And I’ve been through the service manual and it just shows the removal and installation of everything and gives the specs but doesn’t show how to check it
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #26 ·
Always check the easy stuff first!
I had checked it the day, it started acting up. It was still flowing fuel didn’t seem stopped up. But I went ahead and put a new one on it today and it fired right up. Now just how long, before something else, causes it to stop running again, is my question. I know I still have to tear it apart and change the bottom jug gasket it’s leaking oil right on top of drive shaft joint. Which that’s is going to be a pain for me to do.
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #27 ·
I had checked it the day, it started acting up. It was still flowing fuel didn’t seem stopped up. But I went ahead and put a new one on it today and it fired right up. Now just how long, before something else, causes it to stop running again, is my question. I know I still have to tear it apart and change the bottom jug gasket it’s leaking oil right on top of drive shaft joint. Which that’s is going to be a pain for me to do.
plus, I still haven’t solved the irritating, oil temp light coming on, after an hr of easy riding still.
 
21 - 29 of 29 Posts
Top