Suzuki ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi there , I have a 2018 Suzuki king quad. The other day I was riding up a hill in 4x4 low. It wasn't a crazy climb, but the snow was a bit deep. Once I got to the top and let off the gas it stalled. Started it up right after, ran a bit rough for a few seconds.

Same thing happened to me today. I was in 4x4 low, climbing a hill with some deeper snow and some challenging sections. Once at the top I let off the gas and it stalled. It did start right back up though.

In the summer I notice that after climbing a big hill or a challenging section when I let off the gas, it almost seems like it is going to stall but9 then recovers and idles back to normal.

Any idea what is going on? There is never an issue with lack of power, I always have lots of that. It is just when I stop.


Matt
 

·
Super Moderator
Joined
·
8,265 Posts
Try checking your TPS sensor, (Throttle Positioning Sensor). And welcome to the Forum.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Hi there , I have a 2018 Suzuki king quad. The other day I was riding up a hill in 4x4 low. It wasn't a crazy climb, but the snow was a bit deep. Once I got to the top and let off the gas it stalled. Started it up right after, ran a bit rough for a few seconds.

Same thing happened to me today. I was in 4x4 low, climbing a hill with some deeper snow and some challenging sections. Once at the top I let off the gas and it stalled. It did start right back up though.

In the summer I notice that after climbing a big hill or a challenging section when I let off the gas, it almost seems like it is going to stall but9 then recovers and idles back to normal.

Any idea what is going on? There is never an issue with lack of power, I always have lots of that. It is just when I stop.


Matt
I had an issue with low idle or low speed stalling, the 3rd shop figured it out and I just got it back today, only one test ride but is looking promising, they replaced voltage regulator and battery. Will be getting some more riding in shortly as I care for the local ice rink, power broom or plow then surface. Will let ya know if it's a fer real fix.
 

·
Registered
Joined
·
4 Posts
I had an issue with low idle or low speed stalling, the 3rd shop figured it out and I just got it back today, only one test ride but is looking promising, they replaced voltage regulator and battery. Will be getting some more riding in shortly as I care for the local ice rink, power broom or plow then surface. Will let ya know if it's a fer real fix.
P.S. First thing I replaced myself was the TPS and it didn't help, so I have a spare now....
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
I had an issue with low idle or low speed stalling, the 3rd shop figured it out and I just got it back today, only one test ride but is looking promising, they replaced voltage regulator and battery. Will be getting some more riding in shortly as I care for the local ice rink, power broom or plow then surface. Will let ya know if it's a fer real fix.
Perfect thanks for the info
 
1 - 6 of 6 Posts
Top