Suzuki ATV Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
My uncle haves the above machine yesterday if you gave it more then half throttle it would stumble and want to die,idle good started good revived up fine in neutral. We topped the gas tank off and it came out of it for about 15 miles then started acting up again. I’m thinking fuel pump.. it’s only got 2100ish miles on it .. what you say all??
 

·
Registered
2020 KingQuad 750
Joined
·
215 Posts
Sounds like fuel ... but could be other things. Maybe try cleaning the fuel injector? Change the plug. Check the plug wire and make sure its connected tight to the coil. Kind of a newer machine and low miles for fuel pump issue, but it's possible. I'd try cleaning everything you can, check all the electronic connections you can get to. Is it throwing any codes?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
I don’t know how to pul the Codes on this machine and thanks for getting back with me. What throws me off is we put like two gallons of gas in and it ran great for about 15 miles and started acting up again. Kind of thinking vapor locking but I haven’t heard of anything doing that in years ????? And yes it does say chec on the gauge but that’s been on there for awhile and that might be related to his power steering. He’s a cancer survivor and is on a fixed income. So stealership is out of the question! I’m going to check some things tonight after work and try and figure this thing out !!! Any and all help is appreciated 👍👍👍👍
 

·
Registered
2020 KingQuad 750
Joined
·
215 Posts
Ya, I get ya. Adding the gas and having it run good may just be a coincidence. Did you let it cool down and then run it after filling? Maybe its getting to a certain temp and then cutting out .... that would make me think electrical. So, there's a thread on here about jumping the circuit on the diagnostic plug in under the seat with a paper clip to put it into diagnostic mode to see if there is a code. It's really simple to do. Maybe someone can post the link to it. I bet you its throwing a code and that could really tune you in to whats goin on. Someone else had this problem a little while ago on a 2019 I think. If its the fuel pump, it would most likely throw a code for the fuel pump relay.... I think.
 

·
Registered
2020 KingQuad 750
Joined
·
215 Posts
Here's the post showing where and how to jump the diagnostic plug to get the machine into dealer mode ... which will read service codes if one is present. I have the plug-in with toggle switch, but if your careful, the paper clip jump should work fine. Once in Dealer mode, you can toggle around with the buttons on the dash to see any codes.


Sleeve Gesture Font Magenta Bag
 

Attachments

·
Registered
Joined
·
18 Posts
Discussion Starter · #6 · (Edited)
Yeah kind of did two things at once opened the cap (vented pressure) and added gas did the gas cool the pump down to get us closer to the pickup or did we vent the pressure lol got some work to do thanks for the help 👍👍
 

·
Administrator
Joined
·
9,435 Posts
This video describes how to put your atv into dealer mode using a paperclip. This video is done on a 2019 King Quad 750, though the procedure should be the same on your model. This video is mainly showing you how to reset the service minder light. But to do so you still need to put it into dealer mode. Which should pop up any codes that are present if any.

 
  • Like
Reactions: Hillsdweller

·
Super Moderator
Joined
·
1,121 Posts
My uncle haves the above machine yesterday if you gave it more then half throttle it would stumble and want to die,idle good started good revived up fine in neutral. We topped the gas tank off and it came out of it for about 15 miles then started acting up again. I’m thinking fuel pump.. it’s only got 2100ish miles on it .. what you say all??
Not counting the fuel you just put in, how old is the rest of the fuel?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #10 ·
Last ride was 2 weeks ago we run 91 so no ethanol and that’s the only reason we run 91. He’s been driving it around all afternoon and of coarse it’s not acting up. But Sunday was way hotter outside I’m headed home here shortly so I’m getting ready to tare into it hopefully he haves all the plastics off for me lol .
 

·
Super Moderator
Joined
·
1,121 Posts
Last ride was 2 weeks ago we run 91 so no ethanol and that’s the only reason we run 91. He’s been driving it around all afternoon and of coarse it’s not acting up. But Sunday was way hotter outside I’m headed home here shortly so I’m getting ready to tare into it hopefully he haves all the plastics off for me lol .

So the oldest fuel is two weeks old?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #15 · (Edited)
He’s working on getting the plastics off and I’m eating quick but I did check his gas cap and when you tighten it it just clicks when it’s tight so that should be a venting cap ??? Right??
 

·
Super Moderator
Joined
·
1,121 Posts
He’s working on getting the plastics off and I’m eating quick but I did check his gas cap and when you tighten it it just clicks when it’s tight so that should be venting cap ??? Right??
The clicking is normal. Tighten it until it clicks and you are good.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #17 ·
Yes but does it vent the tank is my question I don’t have an air compressor at home so I’m going to take the cap to work tomorrow and make sure I can blow air though it gently. for the record I align over the road tractor trailers alignments and suspension is my bread and butter but I’m no motor electric dude. I know enough to get around
 

·
Registered
2020 KingQuad 750
Joined
·
215 Posts
No, the 4-1 and 4-2 are not codes .... unless that is something separate I dont know about. The power steering codes will show up as C111 to C1155 and the other non-power steering codes will show up as C13 to C65. They will show up right where they mileage is displayed on the dash. Now that you mention eps, there have been multiple posters on here who have had power steering issues that have caused the machine to stall and run funky.
 

·
Registered
2020 KingQuad 750
Joined
·
215 Posts
So just another observations after reading thru the fuels system section of the shop manual. There is a mesh boot attached to the bottom of the fuel pump that is a filter. If that was clogged or really dirty form some bad fuel in the past, that may be a cause for the symptoms you are having. It can be so many different things though. You'll be Really Lucky if you hit it on the head the first time. Also .... there is also pressure released on my King when I unscrew my gas cap ... depending on the amount of fuel left in the tank.
 
1 - 20 of 28 Posts
Top