Suzuki ATV Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
This is my first attempt in a forum. My 2017 KQ750 axi started setting code c-91 and the speedo quit. I also lost power steering but the EPS light goes out. I'm thinking it may be a cluster problem. I cannot find any bad wires. All fuses and powers are good. I have not found a specific thread to point to a diagnosis. I am wondering if anyone has had this combination of problems?
 

·
Registered
Joined
·
309 Posts

·
Registered
Joined
·
309 Posts
This is interesting as well, it says a C91 code will cause a bike to go into limp mode which might be why your power steering is not working? Just something to think about. c29 code cleared then c91 came up on 2008 gsxr 1000

I recall seeing an adapter to hook a Suzuki car code reader to a KingQuad diagnostic port. Not sure if that will get you anymore info but something to look into as well. A factory service manual would probbaly help a lot as well.
 

·
Registered
2020 KingQuad 750
Joined
·
258 Posts
My 2020 shop manual says:
C91 - Vehicle Speed Sensor Circuit Malfunction (Speed sensor signal is not input to ECM for 6 seconds or more when the vehicle is running.)
Attached are the 3 pages from manual for diagnostic check/repair. Hope this helps.

White Font Rectangle Line Material property


Font Parallel Pattern Diagram Drawing


Font Rectangle Material property Parallel Pattern
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
When googling Suzuki C91 code this came up, it is for a GSXR motorcycle but i assume they are very similar. "Failure in communication between ecm and speedometer with reference to vehicle speed. "

Do you take the ATV in deep water?
I do not mud or take it in deep water unless on the ice in the winter. I suspected it may loose power steering with a code but I'm not sure. I will check the sensor more next. Thanks
My 2020 shop manual says:
C91 - Vehicle Speed Sensor Circuit Malfunction (Speed sensor signal is not input to ECM for 6 seconds or more when the vehicle is running.)
Attached are the 3 pages from manual for diagnostic check/repair. Hope this helps.

View attachment 22396

View attachment 22397

View attachment 22398
Very helpful, thank you
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
I do not mud or take it in deep water unless on the ice in the winter. I suspected it may loose power steering with a code but I'm not sure. I will check the sensor more next. Thanks

Very helpful, thank you
There is no continuity through the speed sensor so I will locate one and see if that is the whole issue.
 
1 - 8 of 8 Posts
Top