Suzuki ATV Forum banner

1 - 7 of 7 Posts

·
Super Moderator
Joined
·
8,111 Posts
Dash is yellow no start , gogg TV it to fire on fluid
What..? Can you please take the time to make sure your spelling is correct. Hard to understand what your asking when your sentences are garbled. And is your King Quad a 700..? That’s the only model King Quad I could find that was made in 2005 when I looked it up. And welcome to the Forum.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Sorry about that , 2005 kq700 I got it to run bypassing the relay under the seat . Bought a new relay and fuel pump still won’t turn on . All the fuses are good. The dash is just a yellow color light no numbers or anything . What would be my next step ?
 

·
Super Moderator
Joined
·
8,111 Posts
Hummm, I was going to ask if your quad was throwing any error codes. But that’s kind of hard if your have no numbers showing up on the display.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
So does the ecu control the dash display also ? Just crazy that I can bypass the relay and it runs , guessing it’s a 400 bucks for ecu
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Just to let everyone know my issue was broken wire . Left side in wire bundle three red wires meet up . With one red wire it was broke added a jumper wire and up and running along with dash !! Hopefully it will help someone down the road
 

·
Super Moderator
Joined
·
437 Posts
Just to let everyone know my issue was broken wire . Left side in wire bundle three red wires meet up . With one red wire it was broke added a jumper wire and up and running along with dash !! Hopefully it will help someone down the road
Glad you found it and are back operational. Thanks for sharing your findings. Hopefully it will help someone.
 
1 - 7 of 7 Posts
Top