Suzuki ATV Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
My 1999 seems to idle great and slowly revs up fine. Once I get at about half throttle, it sputters and starts to knock like it’s going to stall.

Any ideas?
 

·
Super Moderator
Joined
·
7,479 Posts
Give your carb a good cleaning. Most likely the high speed jet is clogged up giving you issues.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
14 Posts
I had a similar problem with my 99. Tore into my carb 3 times to clean it and change or adjust jets, pita, changed out the fuel pump, still no fix. Changed the fuel petcock, runs like a champ. Motor/carb was starving for fuel the whole time.
 

·
Registered
Joined
·
44 Posts
I have had a similar issue. Mine was the carberator cleaning issue, but have heard of multiple instances of the petcock problem being the correct fix as well. Good luck.
 

·
Super Moderator
Joined
·
7,479 Posts
It can very well be the fuel petcock. I’ve had to change mine out. Though when mine crapped out my bike wouldn’t idle, it backfired, it hesitated, and had no power. So the symptoms can vary. It easy to check anyhow. Simply pull the vac line (Smaller Line) off at the fuel petcock. If the line is wet or fuel comes out of it or the port where you removed that line, then the fuel petcock is bad. If not the issue lays most likely within the carb.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
I recently purchased a 1995 300KQ 4x4 and it wasnt running when I bought it. Previous owner said it wasnt firing. I did not get a key with the ATV so I bought a new ignition and put it in. Turns out this was firing problem. The ATV starts fine and idles fine but sputters upon acceleration. Bought a new spark plug and replaced today, same problem, old spark plug was black and had unburned fuel on it...need help on waht is causing this issue
 

·
Registered
Joined
·
98 Posts
Is an oem suzuki carb or a cheap China carb, if it's not oem thats your problem. China carbs dont work right
 

·
Registered
Joined
·
18 Posts
I continue to read how cheap Chinese carburetor doesn’t work. I have used them on generators, lawnmower, wheelers n such. Probably have 5 rigs with cheap carbs. And the ones i have used work good. Replacing the carburetor is cheap and fast. If they are not the best performers they will usually get you going, in the right direction. Especially if there are multiple problems with the engine.
They are a tool. Take them for what they are. Especially on wheelers. Oem stuff is just no comparison on costs. 25 bucks compared to 200 bucks. I don’t know what you’re time is worth but I have to work on stuff like this daily. The biggest problem that i have is that these motors in rigs don’t get ran enough. Moisture in the case or block, all the way to the exhaust. How many vehicles have you seen with water dripping out the exhaust? Seals and their mating surface are effected throughout the entire machine. I just put a cheap carburetor on a Honda 185 i picked up cheap. Guy says it uesd to run. But won’t now. I have no idea what has happened prior. I know that a cheap carb has all the parts. In the right order. And is clean . And will get me in the ballpark. And for me, has dealt with the problem again. I now have a rebuilt oem carburetor on the shelf for that 3 wheeler if I need it and was able to rebuild the carburetor on my schedule.
Kind of go on a bit but I think some folks just repeat what they read on the net or heard somebody say something. Not actual hands on experience.
 

·
Registered
Joined
·
6 Posts
These answers are not helping me much at all lol but yeah a carb is a carb I have used oem and aftermarket and not seen a difference
 

·
Super Moderator
Joined
·
7,479 Posts
I don’t think people are reiterating what they’ve read on the internet. I’m pretty sure they are are speaking from general experience and knowledge. People are trying to help and give you suggestions. These bikes are very finicky, and I know it. I have one. Just because a knock off carb will work on a Honda, Kawasaki, etc. Doesn’t necessarily mean it’ll work on the KQ’s/QR’s.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
With the air box lid off wouldn't that mean it's not getting enough air when it's on? Just thinking out loud but would the fuel mix be too rich and requireing more air to compensate...? Hmm..

Sorry I've been on a learn/fix quest for a few weeks now so I'm going analytically ape crap still. LOL.
 

·
Registered
Joined
·
6 Posts
Your right about it needing more air but these machines are so finicky like mentioned earlier that im affraid to mess with any ajustments on the carb lol
 

·
Super Moderator
Joined
·
7,479 Posts
The carbs on these bikes are hard enough to get at, yet alone adjust/set correctly if something is off. Maybe getting the carb cleaned and a kit installed by a professional is the way to go. I had mind done about 4 years ago.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
My 99 KQ 300 has similar issues. It starts and idles great but sputters and backfires when revving. I replaced the original carb with a Chinese first, then sacrificed another KQ for a good OEM carb with same results. Digging deeper I replaced fuel pump, coil, CDI, spark plug and wire with donors or new components. I tried the "headlights on" test to check the regulator/rectifier issue. I eliminated the air box and plumbed in a simple air filter under the seat. I bypassed the fuel tank and used a gravity test to fuel the carb to eliminate the petcock issue with no change. I tested the intake boot for air leaks, pulled it and resealed with gasket shellac for good measure. Exhaust doesn't appear blocked as it has pressure there too. Looks like I am down to a mechanical issue, however the compression test was good at 120-125 psi. Anyone get this far and still not resolve the issue?
 

·
Registered
Joined
·
94 Posts
114 psi is the absolute minimum for compression according to the manual, should be 140-199.... So yours at 120 is getting pretty low..

Have you tried adjusting valves?
 
1 - 20 of 23 Posts
Top