Suzuki ATV Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello all any help would greatly be appreciated my atv is stalling mostly when going downhill when I’m off the throttle. It starts fine and idles good. When on the throttle runs good plenty of power. I’ve changed fuel filter six months ago and the stalling went away but now has come back. Runs good in 2wd and regular 4wd. But now when I shift in 4wd differential lock it has a terrible miss. Change spark plug and cleaned gas tank out again. Neither has helped the random stalling. Also adjusted the idle up slightly. No help adjusted it back. I tried sea foam and use Sta bil. I really only use it for hunting and snow plowing my driveway.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
Hello all any help would greatly be appreciated my atv is stalling mostly when going downhill when I’m off the throttle. It starts fine and idles good. When on the throttle runs good plenty of power. I’ve changed fuel filter six months ago and the stalling went away but now has come back. Runs good in 2wd and regular 4wd. But now when I shift in 4wd differential lock it has a terrible miss. Change spark plug and cleaned gas tank out again. Neither has helped the random stalling. Also adjusted the idle up slightly. No help adjusted it back. I tried sea foam and use Sta bil. I really only use it for hunting and snow plowing my driveway.
Well my problem has returned. It’s driving me crazy. I checked and cleaned all my battery connections and the ground. I did put a new rectifier on. Didn’t help. Bike idles fine and runs good when on the throttle.
Where I ride is very rocky and steep. The ride up i have no issue but the ride down when I’m not on the throttle is when it stalls. Any help would be appreciate!
 
1 - 6 of 6 Posts
Top