Suzuki ATV Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello all any help would greatly be appreciated my atv is stalling mostly when going downhill when I’m off the throttle. It starts fine and idles good. When on the throttle runs good plenty of power. I’ve changed fuel filter six months ago and the stalling went away but now has come back. Runs good in 2wd and regular 4wd. But now when I shift in 4wd differential lock it has a terrible miss. Change spark plug and cleaned gas tank out again. Neither has helped the random stalling. Also adjusted the idle up slightly. No help adjusted it back. I tried sea foam and use Sta bil. I really only use it for hunting and snow plowing my driveway.
 

·
Super Moderator
Joined
·
7,302 Posts
Did you try adjusting the TPS, (Throttle Positioning Sensor)..? Or at least check to see if it’s within spec..?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Changed both ground wire and positive wire. Had it out twice since hasn’t stalled once.
Thanks
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Just a follow up. Had my bike out several times since changing the battery cables. Bike is running great! 👍
 

·
Registered
Joined
·
1,688 Posts
Thanks for the update
 

·
Registered
Joined
·
37 Posts
It may be possible that its the rev limiter ( grey button) on the handlebar. Many believe these are just for reverse (including my own dealer) and they are not. Maybe its dirty inside. It is simple enough to try!
 
1 - 9 of 9 Posts
Top