Suzuki ATV Forum banner
ltz400
1-7 of 7 Results
  1. Suzuki QuadSport
    I am looking for some advice. I have a 2007 Z400, with a 434BBK, full yoshi exhaust, and no airbox lid (don't have it, never had it, gone before i got it). I have played with jetting and i have gotten it to run better, but it still is not right. I know it is rich at idle, and possibly...
  2. Repair and Maintenance
    Hey guys, new member here but this page has already helped me out a bunch. But I got a 03 Suzuki ltz400 quad sport, that is having trouble starting when hot. When it’s cold it starts right up, but once you run the bike for about 10 mins the bike won’t turn on unless it cools down. I have...
  3. Brakes & Suspension
    So I recently bought a ltz 400 and noticing the rear brake pads where down to the backing plate so I decided it was time to do all of the brakes. I changed the front pads and the front brakes and they would take a few pumps to build pressure for whatever reason. Then I decided to put a new meter...
  4. Suzuki QuadSport
    Hello, i have a 2003 suzuki ltz 400 and after summer ended I put my quad in storage meaning I drained all the gas and ran the quad until it didn't run. The other day I went to start it up and it idled perfectly so I let it warm up and I gave it some throttle. At about half throttle it sounded...
  5. ATV General Discussion
    New here. Bought a project. 2004 LT Z400. hook up the battery, turn the key and flip switch to run. No lights no click from the starter, I got nothing. The coil and ignition switch were recently replaced, although that doesn’t necessarily mean anything. Anyway, I jump it from the starter and I...
  6. Repair and Maintenance
    I have purchased an '04 LTZ 400 from a friend of mine. The front right lower ball joint is completely destroyed, so I need to get it replaced. After much searching I have come to the conclusion that I need to simply buy a new front right lower wishbone arm, since from the factory the ball joint...
  7. ATV General Discussion
    So I have a 2007 Ltz400 bought it new off of the show room floor and ran it for about 2 years and blew it up. Put a new cylinder on it rod bearings piston rings and rod and all new gaskets. Now it will not run with the petcock on the on position. and it runs on prime but cuts out when you open...
1-7 of 7 Results
Top