Suzuki ATV Forum banner

help

  1. ATV General Discussion
    Hello, I recently purchased my Suzuki Quadrunner 4wd 1992 and need help with it. It turns on fine, then while it on but not running I believe it is oil and gas going into the air box filter, liquid falls then it completely shuts off once it spills into the box.
  2. Repair and Maintenance
    New here and was hoping I might be able to find some advice got a used 99 quad runner 500 4x4 last summer ran great at first towards the end of fall I noticed it smoking from the rectifier so headed home and mid way just died on me lost power to everything. Not much experience with the...
  3. Suzuki Eiger 400
    OK so I have a 2002 Suzuki eiger 400 that clicks but won’t start. it has a new battery, new neutral switch relay, new starter solenoid, new starter motor, and all fuses are good. I bench tested the new starter and it spins fine with a known good battery with 220 cold cranking amps. Battery is...
  4. New Member Introductions
    Hello everyone, names Josh from Ohio. I have a few toys that are newer and run perfectly but for some reason I love riding this d*** KQ lol. Now its not new obviously and its in just about the worst condition you could imagine physically but its a dog, when its running its a work horse and it...
  5. Repair and Maintenance
    I have recently purchased an Eiger from an older gentleman who just drove it back and forth to the deer stand. It would only run with the choke on when I got it but I cleaned the carb and it’s back to running great. With that being said it won’t go over 25 mph. Each gear gets progressively...
Top