cant get more than idle - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 09-15-2019, 04:38 PM Thread Starter
Suzuki ATVer
 
jebinga's Avatar
 
Join Date: Sep 2019
Posts: 3
Angry cant get more than idle

im at a loss, i have an 07 k.q. 700 that wont take fuel. its hard to start and will only run a few sec. and cut off. if you touch the throttle it dies instantly. its getting fuel air spark compression..put in a new air filter, new plug, checked the woodruff key for spark timing thats behind the fly wheel. checked the fuel pump and filter too. 3 shops have looked at it and even suzuki has no idea..anyone have any ideas?
jebinga is offline  
Advertisement
 
post #2 of 5 Old 09-15-2019, 05:20 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 7,276
Send a message via Yahoo to ajl719
Have you taken a look at the TPS if your quad is equipped with one..?


Sent from my iPhone using Tapatalk

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
14,000 + km/s
ajl719 is offline  
post #3 of 5 Old 09-15-2019, 06:49 PM Thread Starter
Suzuki ATVer
 
jebinga's Avatar
 
Join Date: Sep 2019
Posts: 3
yes, i forgot to add that, tps is set whee it should be
jebinga is offline  
Advertisement
 
post #4 of 5 Old 09-15-2019, 09:04 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 7,276
Send a message via Yahoo to ajl719
cant get more than idle

Hard starts can sometimes be attributed to out of spec valves. Have you checked the valve clearances to see if their still within spec..? Not sure how that would affect your more then idle issue if they are.


Sent from my iPhone using Tapatalk

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
14,000 + km/s
ajl719 is offline  
post #5 of 5 Old 09-16-2019, 10:02 AM Thread Starter
Suzuki ATVer
 
jebinga's Avatar
 
Join Date: Sep 2019
Posts: 3
dealer checked valves and said they were in spec, any other ideas?
jebinga is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
99 King Quad 300 idle issues Letzride Suzuki KingQuad 300 7 02-21-2019 01:50 PM
Ozark 250 won't idle but runs fine off idle Dguysk01 Suzuki Ozark 8 12-08-2018 09:05 PM
07 kingquad starting and low idle issue Justin Lannartson Suzuki KingQuad 1 10-12-2018 03:56 PM
08 KQ 750 Idle issue DuckNasty Suzuki KingQuad 9 08-01-2017 02:15 PM
High/Rough Idle Problem Solved dougr583 Suzuki KingQuad 300 1 12-14-2016 05:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome