2011 KQ 750 AXi Won't Start - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 08-12-2019, 06:48 AM Thread Starter
Suzuki ATVer
 
ravila@dadeschools.net's Avatar
 
Join Date: Aug 2019
Location: Miami, FL and Okeechobee, FL
Posts: 2
2011 KQ 750 AXi Won't Start

Good morning to all, new to the forum as i just bought a second hand KQ 750AXi that appears to be in great shape and runs exceptionally well when it starts.

Problem comes in when i try to start it. key is set to start, switch is on, i press the start button and it turns over but does not fire up. The couple of times that i got it started was by playing around with key, turning it off/ on. You can hear clicking and the sound of a pump running but the bike doesn't fire up.

Taking it in for service but just looking for possible causes. Any insight is greatly appreciated.
Advertisement
 
post #2 of 4 Old 08-12-2019, 07:17 AM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 7,228
Send a message via Yahoo to ajl719
Bad fuel injector, valves might need adjusting.


Sent from my iPhone using Tapatalk

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
14,000 + km/s
ajl719 is offline  
post #3 of 4 Old 08-12-2019, 09:50 AM Thread Starter
Suzuki ATVer
 
ravila@dadeschools.net's Avatar
 
Join Date: Aug 2019
Location: Miami, FL and Okeechobee, FL
Posts: 2
ajl719, You are right on point. Mechanic just looked at it and said the same thing.

Thank you for the feedback!!!
Advertisement
 
post #4 of 4 Old 08-12-2019, 05:36 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 7,228
Send a message via Yahoo to ajl719
No problem. Glad to help.


Sent from my iPhone using Tapatalk

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
14,000 + km/s
ajl719 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
QuadRunner 500 2002 No Start, Will Pull Start JohnM Repair and Maintenance 2 12-28-2017 06:42 PM
Vinson electric start is dead mattf138 Repair and Maintenance 0 11-12-2017 02:58 PM
2011 Suzuki Kingquad 400 ASI Won't Start bwmcmaster23 New Member Introductions 0 06-23-2017 09:17 PM
2011 750 won't start spencer_clark30 Suzuki KingQuad 6 07-06-2016 01:00 PM
2011 Suzuki Kingquad 750 won't start DanHalen ATV General Discussion 12 06-01-2016 06:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome