2005 Ozark LT-250 Bogs at full throttle and backfires aswell - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 07-21-2019, 08:49 PM Thread Starter
Suzuki ATVer
 
Monkeygaming032's Avatar
 
Join Date: Jul 2019
Posts: 3
I've checked just about everything (carb cleaned, spark plug,fuel tank, fuel lines) only thing I haven't checked is the ignition timing but I don't know if that can cause that and I don't have any idea how to check or adjust that. ( Idles perfect and runs ok at min to medium throttle)

Last edited by Monkeygaming032; 07-21-2019 at 08:52 PM.
Monkeygaming032 is offline  
Advertisement
 
post #2 of 5 Old 07-21-2019, 09:12 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 7,233
Send a message via Yahoo to ajl719
2005 Ozark LT-250 Bogs at full throttle and backfires aswell

Im assuming your bike has a fuel petcock..? Its the valve under your tank which allows you to switch from On/Pri/Res. The fuel petcocks on some of the 250 QRs and 300 KQs are known to go bad. When or if they go bad, your bike can get all sorts of problems. Such as: Stalling, backfiring, hesitation, power loss, and poor idling. If bad enough, it can dump fuel into the crankcase contaminating your oil. To check the fuel petcock, pull the vacuum line (Smaller Line), off at the fuel petcock. If fuel comes out the line or port where you removed that line. Or if the line is wet. Your fuel petcock is bad and needs to be replaced.


Sent from my iPhone using Tapatalk

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
14,000 + km/s

Last edited by ajl719; 07-22-2019 at 06:26 AM.
ajl719 is offline  
post #3 of 5 Old 07-21-2019, 09:27 PM Thread Starter
Suzuki ATVer
 
Monkeygaming032's Avatar
 
Join Date: Jul 2019
Posts: 3
Ok I'll check that out
Monkeygaming032 is offline  
Advertisement
 
post #4 of 5 Old 07-22-2019, 08:34 AM Thread Starter
Suzuki ATVer
 
Monkeygaming032's Avatar
 
Join Date: Jul 2019
Posts: 3
Ok so I removed the line from the fuel petcock and fuel started to come out of the port and the line was wet aswell so I guess my petcock is bad like you said.
Monkeygaming032 is offline  
post #5 of 5 Old 07-22-2019, 09:25 AM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 7,233
Send a message via Yahoo to ajl719
Sounds like it. You can band-aid fix it by capping the vacuum port on the fuel petcock and the vacuum port on the carb and running your carb with the fuel petcock set to the Pri position. Only set it to this position while running the quad as Pri is gravity fed and will contaminate your oil if left in this position with the quad off. OEM fuel petcocks are a little bit pricey, but worth it in my opinion.


Sent from my iPhone using Tapatalk

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
14,000 + km/s
ajl719 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1990 Lt-250s Cutting out at full throttle 1knighking Repair and Maintenance 9 10-14-2016 09:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome