4x4 shuts bike off - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-05-2019, 06:57 PM Thread Starter
Suzuki ATVer
 
Tgibbons96's Avatar
 
Join Date: Jun 2019
Posts: 2
4x4 shuts bike off

Hi i am new to the forum, i have a 2009 king quad 750 base model, purchased a month or two ago 140hrs and 1000 miles, recently i have noticed when riding that when i push the 4x4 button it will stall the bike, had a local repair shop look at it and they came up with nothing, bike will restart and run fine after it stalls and does not stall every time i lock into 4x4, unsure of where to start looking, any help or tips appreciated!
Tgibbons96 is offline  
Advertisement
 
post #2 of 4 Old 06-06-2019, 03:59 PM
Suzuki ATV Master!
 
TCIII's Avatar
 
Join Date: Nov 2013
Location: texas
Posts: 1,652
Sounds like a short somewhere between the button and the actuator.....or the actuator it self.

2002 King Quad 300
2001 King Quad 300
1997 King Quad 300
1997 quad Runner 250 2x4
2008 Kawasaki 250 Bayou 2x4
2013 TaoTao 110
TCIII is offline  
post #3 of 4 Old 06-08-2019, 11:41 PM
Suzuki ATV Master!
 
TheBearAK's Avatar
 
Join Date: May 2014
Location: Middle of Alaska
Posts: 1,740
If the actuator is struggling to do its job, it can put a draw on the system.

To much draw it can struggle with the fuel injection, which will cause it to stall.

Possible short, possible worn or gummed up actuator. Possible weak battery.


Why battery?

The stator on these only puts out 170-180 watts. About half of that is required for the EFI. So machines with extra lights, power steering, or anything else that draws power will draw any extra power from the battery. If the battery is weak, it causes the EFI to stumble.

2013 Suzuki King Quad 500 AXi w/EPS
1990 Suzuki LT-4WD 250
and lots of snowmachines
TheBearAK is offline  
Advertisement
 
post #4 of 4 Old 06-11-2019, 09:43 AM Thread Starter
Suzuki ATVer
 
Tgibbons96's Avatar
 
Join Date: Jun 2019
Posts: 2
Bike has brand new battery, problem persists sporadically, sometimes nothing happens others it shuts off, how can I test the system to be sure it’s an actuator?
Tgibbons96 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Eiger shuts off cpipes3 Suzuki KingQuad 1 09-30-2016 08:46 AM
Ltz400 diyingneed bike for weekend Caddymk3 Suzuki QuadSport 4 06-03-2016 01:48 PM
sometimes shuts off when you give it gas bchunter181 Repair and Maintenance 7 05-24-2016 07:33 AM
11 king quad 750 shuts off when i stop? allimport Suzuki KingQuad 7 01-28-2016 11:09 PM
Shuts off at idle Kenster59 Repair and Maintenance 4 01-20-2016 11:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome