quadmaster 500 backfire issue! - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 Old 11-30-2016, 07:30 AM Thread Starter
Suzuki ATVer
 
dylanoreo777's Avatar
 
Join Date: Nov 2016
Posts: 2
Exclamation quadmaster 500 backfire issue!

We have a quadmaster 500 that will start and idle but when giving it gas it has no power and backfires
-has really good compression
-Carb rebuilt twice
-intake has been checked
-new stator
-new cdi
-new voltage regulator

Any ideas on what could be wrong with it ?
dylanoreo777 is offline  
Advertisement
 
post #2 of 17 Old 11-30-2016, 02:52 PM
Suzuki ATV Junkie!
 
02VinsonAuto's Avatar
 
Join Date: Nov 2015
Location: CT, U.S.A.
Posts: 586
Welcome To The Forum!

-Kyle M.
SOLD (But Not Forgotten) - 2002 Suzuki Vinson LTA500FK2 CVT AUTO 4X4 with too many mods, accessories, customizations, and upgrades to list
Also Sold and will also never be forgotten: 2007 Suzuki RM125, woods/ enduro built, also with too many mods, accesories, customizations, and upgrades to list
02VinsonAuto is offline  
post #3 of 17 Old 11-30-2016, 04:45 PM
Extreme ATV Enthusiast
 
Bwdeaton's Avatar
 
Join Date: Jan 2016
Location: Dayton, Ohio
Posts: 133
Have you checked the timing and the valve clearances?
Bwdeaton is offline  
Advertisement
 
post #4 of 17 Old 12-01-2016, 07:12 AM Thread Starter
Suzuki ATVer
 
dylanoreo777's Avatar
 
Join Date: Nov 2016
Posts: 2
Thanks for the welcome and thank you for your reply
No we haven't checked valve clearances yet we were also thinking it could be the rotor (magneto) we will check valves and see if not that would you try getting a new magneto? thanks for your help
dylanoreo777 is offline  
post #5 of 17 Old 12-12-2016, 09:56 PM
Suzuki ATVer
 
Wasted1's Avatar
 
Join Date: Dec 2016
Posts: 2
I have been working on one with the exact symptoms and have tried everything you have plus a coil and the valve clearance (except the cdi) without any results. The stator and regulator both tested bad and overcharged the system so I was hoping that would fix the problem but unfortunately it didn't. I'm down to either timing chain stretched, maybe bad cam, or keyway sheared. It runs great till you hit 1/2 throttle then it just starts backfiring and loosing power. Please update with any headway you make and I will do the same.
Wasted1 is offline  
post #6 of 17 Old 12-17-2016, 05:07 PM
Suzuki ATV Junkie!
 
KingQuadRunner's Avatar
 
Join Date: Dec 2012
Location: Ontario
Posts: 1,480
Sounds like the timing is off or not advancing at all.

Own Now
-2007 King Quad 450
-1992 Quadrunner 280 (Project)
-1989 Skidoo Mach 1
-1991 JD AMT 626

Sold
-1971 Skidoo Nordic
-1984 Honda TRX 200
-1984 Honda 200ES
-1998 Quadrunner 250
KingQuadRunner is offline  
post #7 of 17 Old 12-17-2016, 07:32 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 7,154
Send a message via Yahoo to ajl719
quadmaster 500 backfire issue!

Have you checked to see if your fuel petcock is bad..? When mine went bad on my 300 KQ it caused backfires, no power, hesitation, no idling, etc. May or may not be the issue, but it's worth checking it to rule it out as a possible cause. To check it, (With Atv Not Running). Pull the vacuum line off at the fuel petcock, (Smaller Line). If the line is wet, or fuel comes out that line or port where you removed that line, then your fuel petcock is bad and needs to be replaced. Again, may or may not be the issue. But never hurts to check it.


Sent from my iPhone using Tapatalk

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
14,000 + km/s
ajl719 is offline  
post #8 of 17 Old 12-18-2016, 06:12 AM
Suzuki ATV Junkie!
 
KingQuadRunner's Avatar
 
Join Date: Dec 2012
Location: Ontario
Posts: 1,480
When mine went the line was mostly dry but when i pulled it of and plugged the end it ran normally again.

Own Now
-2007 King Quad 450
-1992 Quadrunner 280 (Project)
-1989 Skidoo Mach 1
-1991 JD AMT 626

Sold
-1971 Skidoo Nordic
-1984 Honda TRX 200
-1984 Honda 200ES
-1998 Quadrunner 250
KingQuadRunner is offline  
post #9 of 17 Old 12-24-2016, 05:20 PM
Suzuki ATVer
 
Wasted1's Avatar
 
Join Date: Dec 2016
Posts: 2
I have mine on a fuel bottle with the tank removed and the vacuum line plugged off so it's not the fuel valve. Intake gaskets all look good so thinking its a timing problem.
Wasted1 is offline  
post #10 of 17 Old 06-09-2019, 12:12 PM
Suzuki ATVer
 
modus_ponens's Avatar
 
Join Date: Jun 2019
Location: Los Gatos, CA
Posts: 5
Same problem here. Any solutions?
modus_ponens is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
06 King Quad issue. ECM / Electrical issue? Griff70 Suzuki KingQuad 4 03-22-2017 11:10 AM
2000 Quadmaster 500 Briguy92 Repair and Maintenance 5 12-24-2016 09:04 AM
Starting Issue on 1990 QuadRunner LT 4WD jbocook0001 Repair and Maintenance 17 07-30-2016 12:59 AM
1995 Quadrunner "Locked" & Oil Fill Cap Removal Issue ArmedRealtor Repair and Maintenance 3 07-23-2016 03:29 PM
2006 King Quad 700 Timing / Low compression issue wardski Suzuki KingQuad 5 07-01-2016 07:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome