King quad 300 electrical smoke, no power? - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 08-18-2016, 08:53 PM Thread Starter
JCS
Suzuki ATVer
 
JCS's Avatar
 
Join Date: Aug 2016
Location: Chillicothe, OH
Posts: 5
Exclamation King quad 300 electrical smoke, no power?

I was out mowing my food plot today with my 1995 king quad 300 and my bush hog gt42 when I noticed white smoke coming out above the fuel tank and through the battery compartment. I shut the quad off and shut down the bush hog. Went back to the front and it was still pouring out smoke. Smelled it and it was definitely electrical. I didn't have the battery cover on, cause I had just replaced the battery a couple weeks ago and needed to get some replacement nut tabs, so I was able to see the smoke coming from somewhere under the handlebars but not the compartment where the start switch plugs in it was lower then that. I could also hear something sizzling. I let it cool down for a bit and went to turn it back on and have no power. No neutral light, headlights, or starter. I ended up leaving it in the plot for the night gonna try to go back tomorrow to retrieve it between rains.

Any ideas? Figure I'll check the fuses. Not sure where the recitifier is on this bike.

Also may have heard a pop just before the smoke but not sure if it was the bush hog or atv.

A little back story. When i got the quad it would idle but would only sputter under load. Figured out if I left the headlights on it would run. Ended up having to replace the start switch due to wires falling apart. After that it seemed to run fine, even with the lights off, though I did get a whiff of electrical smell here and there. Ran that way over a year with no problems, but never ran the quad very long usually just to check trail cameras. This is the first time I've actually worked the quad.

Last edited by JCS; 08-18-2016 at 09:37 PM.
JCS is offline  
Advertisement
 
post #2 of 9 Old 08-18-2016, 08:57 PM
Extreme ATV Enthusiast
 
Bwdeaton's Avatar
 
Join Date: Jan 2016
Location: Dayton, Ohio
Posts: 133
You will probably need to pull of some plastics and look for burnt wires in the area you saw smoke from. be prepared to tow it back from where it sits, in case you can't get it fixed without tearing down too far.
Bwdeaton is offline  
post #3 of 9 Old 08-18-2016, 09:00 PM Thread Starter
JCS
Suzuki ATVer
 
JCS's Avatar
 
Join Date: Aug 2016
Location: Chillicothe, OH
Posts: 5
Yea I've been trying to locate another quad to pull it out but unfortunately most my friends are hipsters ugh...

Last edited by JCS; 08-18-2016 at 10:03 PM.
JCS is offline  
Advertisement
 
post #4 of 9 Old 08-18-2016, 09:58 PM
Suzuki ATV Junkie!
 
Scott_Tx's Avatar
 
Join Date: Sep 2015
Location: Beckley, WV
Posts: 604
most likely its the rectifier/regulator, mine did the same thing. if you can get in there and unplug it you can prob ride it back out with a new fuse till you get a new one. its a pita to get to, take off the hood and the cover up above it.

---2008 Yamaha Grizzly 450 4x4---
---1999 Suzuki King Quad 300 4x4(sold)---
---2003 Yamaha Vino 50---

Last edited by Scott_Tx; 08-18-2016 at 10:00 PM.
Scott_Tx is offline  
post #5 of 9 Old 08-19-2016, 10:25 AM
Suzuki ATV Master!
 
TCIII's Avatar
 
Join Date: Nov 2013
Location: texas
Posts: 1,659
Having to have the headlights on for it to run properly is pointing toward the rectifier/regulator......it was putting out too much voltage

Be sure to inspect the wiring harness end of the plug for the rectifier ....it's probably fried.

Voltage at the battery while it is running should be around 13.6v-14.7v

2002 King Quad 300
2001 King Quad 300
1997 King Quad 300
1997 quad Runner 250 2x4
2008 Kawasaki 250 Bayou 2x4
2013 TaoTao 110

Last edited by TCIII; 08-19-2016 at 10:27 AM.
TCIII is online now  
post #6 of 9 Old 08-19-2016, 10:43 AM Thread Starter
JCS
Suzuki ATVer
 
JCS's Avatar
 
Join Date: Aug 2016
Location: Chillicothe, OH
Posts: 5
Also prior to this, after I replaced the battery, something would drain it within 3-4 days so I was thinking I had a short somewhere but never checked it.

Last edited by JCS; 08-20-2016 at 09:33 AM.
JCS is offline  
post #7 of 9 Old 08-19-2016, 07:43 PM Thread Starter
JCS
Suzuki ATVer
 
JCS's Avatar
 
Join Date: Aug 2016
Location: Chillicothe, OH
Posts: 5
I was able to get my buddy's tractor running and pulled it out today. I couldn't see any burnt wires or connectors so I unplugged the rectifier and changed the 20a fuse. It fired up so I decided to plug the rectifier in to see if it would smoke again and it started smoking right away. So unplugged it and ordered a new one. Thankful that's all it is. Only problem is the bolts the hold the rectifier are not budging may have to mount elsewhere.

Last edited by JCS; 08-19-2016 at 07:46 PM.
JCS is offline  
post #8 of 9 Old 08-19-2016, 09:51 PM
Extreme ATV Enthusiast
 
dook's Avatar
 
Join Date: Mar 2015
Posts: 356
Did you replace the starter and forget to re-connect the ground wire?
dook is offline  
post #9 of 9 Old 08-20-2016, 09:29 AM Thread Starter
JCS
Suzuki ATVer
 
JCS's Avatar
 
Join Date: Aug 2016
Location: Chillicothe, OH
Posts: 5
I've never replaced the starter just the battery.

Last edited by JCS; 08-20-2016 at 09:34 AM.
JCS is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2016 King Quad vs 2016 Grizzly badbowtie48 Suzuki KingQuad 24 06-24-2017 04:01 AM
Want cheap power for OLDER KING QUAD Mysterykingquad Performance Modifications 9 05-06-2016 10:04 AM
1994 King Quad 300 electrical harness issues MJXCRider Repair and Maintenance 5 04-25-2016 10:58 PM
need info on the 500 king quad kmmdad44 ATV General Discussion 3 03-06-2016 05:32 AM
Suzuki Spark Plug Chart (NGK) ajl719 Repair and Maintenance 2 07-07-2011 10:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome