BATTERY HELP - Suzuki ATV Forum
Performance Modifications Have Modifications? Want to ask about a mod? Having problems with a certain mod? Ask and post here! Carbs, Exhausts, Engines, Etc...

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-06-2019, 05:05 PM Thread Starter
Suzuki ATVer
 
Solokidd89's Avatar
 
Join Date: May 2019
Posts: 1
BATTERY HELP

I have a 2004 Suzuki z400 Quadsport and my battery making a clicking noise and won’t start help guys please.
Solokidd89 is offline  
Advertisement
 
post #2 of 3 Old 05-06-2019, 06:08 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 7,160
Send a message via Yahoo to ajl719
Battery help

Itís not your battery making noise. You have one of 4 possible issues. (1), Your having connections issues. Clean all your connections/terminals and try again. If all is good, apply some dielectric grease to every connection/terminal to prevent further corrosion and help repel water/moisture. (2), your battery is weak and has insufficient charge to start your engine. A weak or dead battery will cause clicking when trying to crank the engine over. (3), Your solenoid may be bad which can also cause clicking when starting the engine. (4), The brushes in the starter are done. In which case you can either buy a rebuild kit or a new starter. Rebuild kits are way cheaper then a new starter if that is the case.

So (1), clean all your connections/terminals starting from the battery, solenoid, and starter. (2), If that doesnít fix your issue, charge up your battery and try again. (3), If none of those two things solve the problem, your issue lays either with the starter solenoid or starter itself. You can bench test the starter to rule rule out the starter or the solenoid to help determine which one is giving you the issue.


Sent from my iPhone using Tapatalk

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
14,000 + km/s

Last edited by ajl719; 05-07-2019 at 03:27 PM.
ajl719 is offline  
post #3 of 3 Old 05-07-2019, 02:43 PM
Suzuki ATVer
 
bparks38652@gmail.com's Avatar
 
Join Date: Oct 2018
Location: MS
Posts: 19
Good advice from ajl719. Experience is a Great Teacher.
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
eiger 2004 4x4 battery charging problems mdupnorth4 Suzuki Eiger 400 7 02-27-2019 06:58 PM
Battery Replacement Steve1886 ATV General Discussion 6 07-06-2018 07:41 AM
Battery type in 2015 KQ 750? Bluenoser Suzuki KingQuad 0 07-30-2017 04:11 PM
How to install a battery charger to Kind Quad 750? tgbowil1 Repair and Maintenance 3 12-26-2016 10:54 PM
Battery blanket / heater for ATV batteries? toonces ATV General Discussion 5 02-04-2016 08:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome