2012 king quad 750 drive train slip - Suzuki ATV Forum
Off-Topic This section is open to anything and everything!

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-30-2018, 08:48 AM Thread Starter
Suzuki ATVer
 
dan68rs's Avatar
 
Join Date: Apr 2018
Posts: 2
2012 king quad 750 drive train slip

I have a 2012 King Quad 750 that slips when driving, especially under fast accelleration. I have gone through the belt drive system and I believe it is all working properly. Is it possible that the rear end is slipping? It acts like it just slips into nuetral but makes a grinding noise while driving. Let off the throttle and it will slip back into gear. I currently have the drive belt exposed (no cover, can see belt while driving), and it looks like it is working properly and is actually slipping behind the drive belt system. Is this possible?
dan68rs is offline  
Advertisement
 
post #2 of 3 Old 07-10-2018, 03:58 AM
Suzuki ATVer
 
RjMaan's Avatar
 
Join Date: Jul 2018
Posts: 11
Well, it looks strange. I think you should also think about changing tires and use the knobby tires. May be the tires are smooth enough that they are not getting good grip over land.
RjMaan is offline  
post #3 of 3 Old 07-10-2018, 11:34 AM
Suzuki ATV Junkie!
 
93kingquad's Avatar
 
Join Date: Nov 2012
Location: western ny
Posts: 834
Garage
Slipping behind the belt system ? What is slipping ? If the belt is slipping behind the clutches then you might wanna get a new belt. As for the grinding noise I would think (like you said) rear end or maybe transmission. I have a suzuki service manual at home for my 08 750. I'll see if the symptoms you are having matches anything.

2008 king quad 750AXI

5000lbs badlands winch with wireless controller
Pro Armor plates (all plates)
Full SYA Warrior riser and snorkel kit
Wild Boar radiator relocation kit ( I hope to be changing soon)
Twin air filter
Dual batteries
Bison hunter series front bumper
EPI mudder clutch kit with EPI severe duty belt
2 inch highlifter lift kit
MSA m20 wheels with 28 inch maga mayhem tires
M109R injector
VDI copperhead ECM (not a very good idea)
R.J.W.C exhaust dirtylife.ca
Front and rear demon axles (been trying to destroy with no luck) came from dirtylife.ca
93kingquad is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 King Quad 500 axi front differential ripped in 1/2 rekluse727 Repair and Maintenance 1 03-23-2018 10:23 PM
2008 750 King Quad Stalling Thread wizkid00104 Suzuki KingQuad 39 02-12-2018 11:14 PM
Lt4wd 250 and lt4wd 300 King quad tire size question. herbertv2 Wheels & Tires 2 03-10-2017 12:54 PM
New 2016 King Quad Millst0ne New Member Introductions 66 02-17-2016 04:58 AM
Suzuki Spark Plug Chart (NGK) ajl719 Repair and Maintenance 2 07-07-2011 10:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome