Suzuki ATV Forum - Reply to Topic
Suzuki KingQuad Discussions for the KingQuad 400,450,750,

Thread: LED Lighting Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-07-2019 08:03 AM
Novak1970 For anyone with an older quad, I just installed this style in my 1985 Suzuki quadsport. Was cheap and quick, with great results.
05-07-2019 06:47 AM
captmyway HI Zuuk!!
that was a superb and informative write up!!! I just purchased a 2019 KQ 750 and want to install those on mine
can you please send me a link also??
thanks again
04-15-2019 08:02 PM
Zuuk
Quote:
Originally Posted by literally a person View Post
Zuuk, thank you for your write up. It was very helpful.
Happy to hear . Thanks !
04-15-2019 07:29 AM
literally a person Zuuk, thank you for your write up. It was very helpful.
02-24-2019 04:48 PM
Zuuk WOW! they look great , canít believe the price too, definitely worth trying them out. It makes a big difference from stock bulbs. I have a LED guy I deal with near me, I never had a problem so far with the Chinese LEDs. I installed a couple of plug and play sets on my old Brute and they went through every weather element for years without issue, still working perfectly when I sold it.

Cheers!
02-24-2019 04:31 PM
JohnDoe1983 This is what I found

https://www.aliexpress.com/item/Moto...AbTest=ae803_3
02-24-2019 04:27 PM
Zuuk Hahaha, I forgot, 2018 model, no pod.. If I helped you brother, thatís thanks enough!

Thanks!
02-24-2019 04:26 PM
JohnDoe1983 Thank you so much ZUUK, very appreciated.

Very good explanation.

I will order 2 right now.

Cheers.
02-24-2019 04:14 PM
JohnDoe1983 Super Wow!!

That is very good explanation.
I have no pod so no problem there.
I will order them right now.

I cannot thank you enough ZUUK.

Cheers.
02-24-2019 03:53 PM
Zuuk Ah ok. No you do not have to remove panels . letís start with the headlights, they are easiest.

See pics..
1) remove outer rubber boot
2) remove inner rubber boot (carefully wires rout into this one but they do have a little play, thatís good)
3) unfasten the spring clip and the whole bulb assembly will come out.
4) disconnect harness from old bulb
5) connect new LED and test, make sure hi low work if not revers the 2 side pole wires , they come out using a precision screwdriver to gently push them out.

For the pod headlight (sorry no pics) youíll need to remove the pod case which is held together with 3 push fasterners (1 on each side and 1 just below the LED display) and 2 screws on the top of the LED display. Once that is done the assembly will come apart and youíll see the bulb, same as the head light to replace.

Hope that helps!
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome