Suzuki ATV Forum - Reply to Topic
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

Thread: Quadmaster 500 misfire Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-19-2019 04:01 PM
TheBearAK Compression? Might be the compression is a bit low. Could be the piston expands as it heats up, so it would get better as it got hotter.

Or it could be a seal/gasket leak that goes away once it heat up.

test compression when cold and hot and see if there is a difference. Compression could be as low as 90 psi and still run. Typical 4 stroke compression should be above 130 psi.
08-18-2019 06:11 AM
Baaaz
Quadmaster 500 misfire

After some ideas, just picked up a quad master 500. In neutral is revs up fine. Under load when cold it misfires. After about 10 minutes of riding itís fine and revs freely.

New plug
Cleaned air filter
Checked fuel valve and filter
Stripped and cleaned carby

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome