4wheel drive will not engage - Suzuki ATV Forum
New Member Introductions If you are new here please post in this section so everyone can get to know you. This will be a kind of icebreaker section for new members.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-10-2019, 06:07 AM Thread Starter
Suzuki ATVer
 
jetomso's Avatar
 
Join Date: Aug 2019
Posts: 2
Lightbulb 4wheel drive will not engage

Hello, New to the forum. Working on a 2004 twin peaks and looking for any insight on correcting the inability to switch into 4 wheel drive. i have read many many post on possibilities. Completely rebuilt both actuators. checked all plug connections and added dielectric grease. Just noticed while making another attempt that there was no speed displayed on speedo. according to what I've read the machine needs to have motion for the front differential actuator to change position.
Also note I have the error code for 2w/4w selector, has been reset a number of time as I've tried different things. Front differential has been completly rebuilt. works as it should when manually engaged/disengaged .

Need to check the speed sensor but I have not been able to locate it. Tips please? Thanks for any help, this forum has provided me many avenues to try.
jetomso is offline  
Advertisement
 
post #2 of 2 Old 08-10-2019, 07:03 AM Thread Starter
Suzuki ATVer
 
jetomso's Avatar
 
Join Date: Aug 2019
Posts: 2
Hi all,
just completed electrical system troubleshooting, only have 4.5v at controller contacts 9 and 10 and
speed sensor displays -4.5v on pins 5 and 10, yes I had the polarity correct.
What could be causing the low voltage? Battery voltage is at 12 plus.

still need to locate speed sensor. All help welcome, this is kicking my back side.
jetomso is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 king quad 4 wheel drive issues ianmcdz Repair and Maintenance 0 07-19-2019 07:04 PM
2003 Suzuki Vinson 4WD won't engage dsutton99 Repair and Maintenance 1 01-17-2019 12:00 PM
2 wheel drive activator switch Steve Williford Suzuki Vinson 500 1 11-20-2018 01:40 PM
Will not engage 4 wheel drive NeDall Suzuki KingQuad 0 02-13-2018 12:13 PM
4 wheel drive won't engage Charlie54 Repair and Maintenance 0 02-14-2016 08:11 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome