New member big issues - Suzuki ATV Forum
New Member Introductions If you are new here please post in this section so everyone can get to know you. This will be a kind of icebreaker section for new members.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-09-2019, 07:54 PM Thread Starter
Suzuki ATVer
 
josephsebalj's Avatar
 
Join Date: Jun 2019
Posts: 2
Just bought a 2001 300 King quad from a guy who hasn't ran it in 5 years, has 1000 km on the bike, bike started fine adjusted the idle, went through all the gears.

When i loaded the bike in the truck it shot out a nasty pile of black oil out of which looks to be a vaccum line hanging down by the exhaust. Cleaned up the mess brought it home, took it for a other spin nothing happenes, changed the oil and filter, turned on the bike and the oil cooler blew. Bought a new uses oil cooler installed it and it blew too.... In need of help
josephsebalj is offline  
Advertisement
 
post #2 of 5 Old 06-09-2019, 10:03 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 7,160
Send a message via Yahoo to ajl719
New member big issues

Is there a blockage someplace within the oil system..? Like on the return line. Lastly, please do not create duplicate threads with the same question in different sub-sections of the forum. Not only does this clutter the Forum. But it won’t get you a reply any quicker. And welcome to the Forum.


Sent from my iPhone using Tapatalk

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
14,000 + km/s

Last edited by ajl719; 06-09-2019 at 10:07 PM.
ajl719 is offline  
post #3 of 5 Old 06-10-2019, 06:41 AM Thread Starter
Suzuki ATVer
 
josephsebalj's Avatar
 
Join Date: Jun 2019
Posts: 2
The lines from the oil cooler back to blow them out? Sorry about the other post I was confused on where to post these issues, thanks for the input and I will try that out.

Can I weld the oil coolers to repair them?
Also is there pressure relief valve somewhere that might be stuck?
josephsebalj is offline  
Advertisement
 
post #4 of 5 Old 06-10-2019, 11:09 AM
Suzuki ATVer
 
Bigfoot's Avatar
 
Join Date: Nov 2015
Location: Ontario, Canada
Posts: 28
Check for a blocked crankcase vent. I'm not familiar with Suzuki's line up as I have only ever owned two...an 85 Quadracer 250 and my current 2015 KingQuad 750. But most if not all 4 stroke crankcases have a vent valve to allow excess pressure out, but nothing back in. If that valve is plugged or the line is kinked, the cases will build pressure and force the oil to wherever the weakest link is. In this case, probably a hose clamp on the cooler blowing the line off.
Bigfoot is offline  
post #5 of 5 Old 06-10-2019, 11:06 PM
Extreme ATV Enthusiast
 
440Tim's Avatar
 
Join Date: Jan 2019
Posts: 122
If it's not a plugged crank case ventilator. Check your compression and do a cylinder leakdown test. Blowby past the rings can pressurize the crank case. It will usually cause oil leaks or blown seals.

Also make sure your oil isn't overfull and use the correct oil for a wet clutch.
440Tim is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suzuki 300 King Quad 4X4 carb issues? rhinoexpress Repair and Maintenance 271 11-09-2016 06:25 PM
New member here DuckNasty New Member Introductions 6 08-11-2016 07:28 AM
1991 King Quad Issues robj749840 Suzuki KingQuad 300 4 06-15-2016 10:23 AM
Suzuki Lt-f250 Quad runner issues Doc1987 Repair and Maintenance 1 04-20-2016 09:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome