New Suzuki owner - Suzuki ATV Forum
New Member Introductions If you are new here please post in this section so everyone can get to know you. This will be a kind of icebreaker section for new members.

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 06-09-2019, 11:20 AM Thread Starter
Suzuki ATVer
 
Kukeshak's Avatar
 
Join Date: Jun 2019
Posts: 3
New Suzuki owner

Hi I just purchased my first ATV. The previous owner told me he thought bike had an injector problem and even provided me with a new injector upon purchase. Well I changed out the new injector and put in a new spark plug. Cleaned all connectors putting dielectric grease all. Well turn on the key hit the button and the bike just spins and will not start. Pulled the plug and che led it's sparking. Rechecked injector still won't start. Eventually "FI" showed on screen. Disconnected the battery to reset the ECU, "FI" disappeared off screen but bike still won't start. Bike was started on trailer backed off and pulled into the shop only parts changed were injector and spark plug. Anyone have a suggestion on what I should check next, any help would be very much appreciated.
Kukeshak is offline  
Advertisement
 
post #2 of 6 Old 06-09-2019, 11:38 AM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 7,201
Send a message via Yahoo to ajl719
Did you check all the fuses..? And what year is it..?


Sent from my iPhone using Tapatalk

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
14,000 + km/s
ajl719 is offline  
post #3 of 6 Old 06-09-2019, 05:45 PM Thread Starter
Suzuki ATVer
 
Kukeshak's Avatar
 
Join Date: Jun 2019
Posts: 3
It's a 2008, yes we checked all the fuses all good
Kukeshak is offline  
Advertisement
 
post #4 of 6 Old 06-09-2019, 09:57 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 7,201
Send a message via Yahoo to ajl719
New Suzuki owner

A 2008, what model..? And try to be as descriptive as possible with your Atv information. This will make it easier for one of us to help you further.


Sent from my iPhone using Tapatalk

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
14,000 + km/s

Last edited by ajl719; 06-09-2019 at 10:02 PM.
ajl719 is offline  
post #5 of 6 Old 06-16-2019, 10:23 AM Thread Starter
Suzuki ATVer
 
Kukeshak's Avatar
 
Join Date: Jun 2019
Posts: 3
It's a 2008 king quad 750x
Kukeshak is offline  
post #6 of 6 Old 06-16-2019, 06:03 PM
Extreme ATV Enthusiast
 
kenora's Avatar
 
Join Date: Jul 2018
Location: Kenora, NW Ontario, Canada
Posts: 166
How many miles...how many hours... is there fresh fuel....

2005 King Quad
2006 Vinson (2 of them)
kenora is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
First time Suzuki owner Bkrcmetalworks New Member Introductions 2 06-12-2018 09:19 AM
New Member First time Suzuki Owner acleast New Member Introductions 3 04-18-2017 06:30 PM
New Suzuki King owner stevo New Member Introductions 12 09-23-2016 07:57 PM
Dad of a Suzuki lt 80 owner cjwim New Member Introductions 1 05-08-2016 08:38 PM
New Owner of Suzuki Quad Runner 250QuadRunner ATV General Discussion 3 05-04-2016 09:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome