King Quad 400 Asi... - Suzuki ATV Forum
New Member Introductions If you are new here please post in this section so everyone can get to know you. This will be a kind of icebreaker section for new members.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-13-2019, 10:34 AM Thread Starter
Suzuki ATVer
 
KQNate's Avatar
 
Join Date: May 2019
Posts: 1
King Quad 400 Asi...

Hello everyone, first post here. So I have a 2012 KQ 400 and have noticed my running lights on the back are not working. I checked the bulb and realize it's a dual element and it seems fine. When taking everything apart I noticed water had got in and I'm guessing ruined the plug that would control my running lights. Brake lights did work but no running lights. What part am I looking for to replace? Any and all help would be greatly appreciated! Thank you!
KQNate is offline  
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
King Quad 300 Expert in the North East (NJ area) ? DTTuner Suzuki KingQuad 300 3 01-10-2018 11:26 AM
2016 King Quad vs 2016 Grizzly badbowtie48 Suzuki KingQuad 24 06-24-2017 04:01 AM
Lt4wd 250 and lt4wd 300 King quad tire size question. herbertv2 Wheels & Tires 2 03-10-2017 12:54 PM
New 2016 King Quad Millst0ne New Member Introductions 66 02-17-2016 04:58 AM
Suzuki Spark Plug Chart (NGK) ajl719 Repair and Maintenance 2 07-07-2011 10:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome