2005 z 250 idle - Suzuki ATV Forum
Suzuki QuadSport Discussions for the Quadsport 50,90,250,400

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-20-2011, 06:29 AM Thread Starter
Suzuki ATVer
 
archer292's Avatar
 
Join Date: Nov 2011
Posts: 8
2005 z 250 idle

I just purchased a used z250 as a Christmass present for my son and it seems that it has some carb problems. Any help to get this figured out would be much appreciated. The vacum line was plugged and it would only run on prime when i got it. Seems the petcock needed to be replaced and this was the way to make it run without replacing it. This was done by a shop for the previous owner and I only learned of it after purchasing the quad and questioning the seller. A new petcock was installed and that's where I come in. The previous owner never had the job finished. So I pulled the carb cleaned everything, set the adjustment screw in the bowl to 3 turns out, reinstalled it and checked for vacum leaks. The bike will start right up and run pretty good but the problem is with the idle. When I use the idle adjustment screw to get the idle where it sounds good and then rev the bike up it hangs at a high idle before settling back down. The only way to get it to settle faster is to lower the idle adjust ment screw, but then the idle is too low. I have tried 3 turns out on the screw in the carb ( not the idle), 4 turns out, and now 5 turns out. At 5 turnsout and fiddling with the idle screw, I can get a decent idle and she will hang very slightly then come down. The hanging occurs when you rev it up and keep it up for a few seconds Not if you are snapping the throttle. Can someone help me out with this? Is the idle hanging normal? I have a 80 honda dirt bike for my son and ride a bike myself and this is not something I can say I have heard before. Thanks for any help in advance.

Anthony
archer292 is offline  
Advertisement
 
post #2 of 4 Old 11-20-2011, 11:42 AM
ATV Enthusiast
 
Mudmaster's Avatar
 
Join Date: Oct 2011
Location: Louisiana
Posts: 54
try adjustig your throttle cable and maybe changing the spark plug, last time that happened to me i just replaced the plug and it was good then
Mudmaster is offline  
post #3 of 4 Old 11-23-2011, 06:17 AM Thread Starter
Suzuki ATVer
 
archer292's Avatar
 
Join Date: Nov 2011
Posts: 8
The bike is jetted for the slip on and a modified box from what I have gathered. 138 main compared to a 125 stock. I will not be running a modified air box just yet. This quad is for an 11 year old and it is the first full size he will be riding. I rebuilt the carb with stock jets but think it will run too lean with the slip on. Ordered a dyno jet kit to have some options on the main. I guess I will start one or two sizes bigger on the main to start.
archer292 is offline  
Advertisement
 
post #4 of 4 Old 12-02-2011, 06:02 AM Thread Starter
Suzuki ATVer
 
archer292's Avatar
 
Join Date: Nov 2011
Posts: 8
A little help !!!! Keep experiencing a hanging idle. If I adjust the idle screw to where she is idleing good the hanging idle is there. If I back down the idle screw I can get the hanging to stop but then the idle is too low.
archer292 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle adjustment viking New Member Introductions 9 10-13-2011 10:51 AM
kq 700 no idle help aj275lbs Suzuki KingQuad 2 10-05-2011 06:18 PM
run away idle kevbz Suzuki QuadSport 4 06-21-2011 08:59 PM
KQ 750 off idle problems, Help! bushboy100 Repair and Maintenance 2 05-14-2011 04:32 PM
Idle Adjustment viking3737 ATV General Discussion 2 04-25-2011 05:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome