A friends 05 700axi fuel and info error..Gremlins - Suzuki ATV Forum
Suzuki KingQuad Discussions for the KingQuad 400,450,750,

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old 12-28-2010, 09:03 PM Thread Starter
Extreme ATV Enthusiast
 
liquid1's Avatar
 
Join Date: Dec 2010
Location: near charlotte nc
Posts: 407
A friends 05 700axi fuel and info error..Gremlins

A friend of mine bought a 05 700 a few months back.
he has been riding it with no problems.
But went down to Carolina Adventure world in sc a few weeks ago and Dragged raced a few other model atv's..He's the 2nd owner and new the first owner, the atv has never been sunk that he knows..
Any how during the Dragg race his FI light came on and Now the Atv want start unless he puts fuel in the intake..Primes it..After he gets it started it will run and never shut off..He keeps a battery tender and Battery checks out ok. so he went online searching forums and read how to check codes on the Nyroc.com forum.
He told me tonight the code read temp sensor bad so he ordered one..huh
Seems fuel related to me.Fuel pump/filter issue...But I;m new to Fuel Injection
I'm going over to his house in morning and were going to check the tank fuel lines and fuel filter up into intake..Anyone have info on possible problem..We have a big ride planned on Friday up in Mtn City tn and he wants to go And I want to ride the 700axi. Since I am thinking of buying a KQ axi soon. His Atv has less than 500 miles on it and runs great he says..but once it sets for a few hours it has to be primed fuel in intake to crank....Could it be dust sucked in the tank clogging fuel system. Can i ground the temp sensor to bypass it to do some test. ..Or do a Diagnostic fuel system test using his Instrument panel..Thanks in advance for any help james..

work hard to play hard.
Just picked me up a nice like new 07 450 Grizzly
Maybe a king 750 axi someday..
Give to my daughter 1998 honda 300FW 4x4 fourtrax
2002 ktm 520 exc dirt bike
http://www.youtube.com/watch?v=D9Gz6Y90Gas

Last edited by liquid1; 12-28-2010 at 09:10 PM.
liquid1 is offline  
Advertisement
 
post #2 of 18 Old 12-28-2010, 09:13 PM
Super Moderator
 
TUBBYTUBB's Avatar
 
Join Date: Sep 2010
Location: Louisiana Boy Living in Central Western Illinois..
Posts: 2,938
Send a message via Yahoo to TUBBYTUBB
I'm not sure of how to test the sensor on one of these but I can tell you about general fuel injection stuff. When you first start something with EFI it is in Open Loop and it is just running off of the mechanical part of the fuel system, IE: Air fuel spark, then once it starts to warm up it goes into Closed Loop mode which is when it starts reading the sensors and such and if the temperature sensor is bad it will either think it is Open/Closed loop depending on what is wrong with it and it can cause all sorts of problems with the computer not knowing exactly what to do to fix it. EFI systems can be real finicky if something is not right.
But I could be incorrect as I know of EFI systems from working on automobiles because I haven't owned or worked on a EFI ATV as of yet.


THOMAS

The One and Only TUBBYTUBB

Click the image to open in full size.
1997 King Quad 300 Still Alive and Kicking Just Giving It A Rest
As In Life: Always Try The Simplest Things First Then Move On to The Bigger Things To Fix The Problems In Front Of You - TUBBYTUBB
TUBBYTUBB is offline  
post #3 of 18 Old 12-28-2010, 09:32 PM
Suzuki ATV Master!
 
zukifreak's Avatar
 
Join Date: Dec 2010
Location: DECIDING WHICH QUAD TO RIDE
Posts: 1,986
The temp sensor basically tells the computer what mixture the engine needs,when it sits and cools and the temp sensor is bad the computer dosent know the engine needs enrichment to start.but when warm the engine needs no enrichment to start.

If it dont work we will fix it while we have our dirty clothes on.Best experience is hands on experience.
IF IT AINT BROKE,DONT FIX IT.
zukifreak is offline  
Advertisement
 
post #4 of 18 Old 12-28-2010, 09:44 PM Thread Starter
Extreme ATV Enthusiast
 
liquid1's Avatar
 
Join Date: Dec 2010
Location: near charlotte nc
Posts: 407
Quote:
Originally Posted by zukifreak View Post
The temp sensor basically tells the computer what mixture the engine needs,when it sits and cools and the temp sensor is bad the computer dosent know the engine needs enrichment to start.but when warm the engine needs no enrichment to start.
Thanks Makes perfect sense. I hope his new part temp sensor fixes his problem. Explains why its starts right up with a little raw gas down the Intake then runs good when warm..Will the computer reset its self or disconneting the batts reset it..FI light is on and theres a error message scrolls acrosss the bottom of display..Sorry for the questions. You sound like your up on these machines..thanks james..

work hard to play hard.
Just picked me up a nice like new 07 450 Grizzly
Maybe a king 750 axi someday..
Give to my daughter 1998 honda 300FW 4x4 fourtrax
2002 ktm 520 exc dirt bike
http://www.youtube.com/watch?v=D9Gz6Y90Gas
liquid1 is offline  
post #5 of 18 Old 12-28-2010, 09:48 PM
Super Moderator
 
TUBBYTUBB's Avatar
 
Join Date: Sep 2010
Location: Louisiana Boy Living in Central Western Illinois..
Posts: 2,938
Send a message via Yahoo to TUBBYTUBB
Yes once he installs the new temp sensor disconnect the battery for about 5 minutes and while it is unhooked flip your light switch on for a couple of seconds this will make sure no power is stored in the system, then reconnect the battery and the computer should be cleared of all codes. Thanks Zuki that is what I was trying to say but you definitely said it better.



THOMAS

The One and Only TUBBYTUBB

Click the image to open in full size.
1997 King Quad 300 Still Alive and Kicking Just Giving It A Rest
As In Life: Always Try The Simplest Things First Then Move On to The Bigger Things To Fix The Problems In Front Of You - TUBBYTUBB
TUBBYTUBB is offline  
post #6 of 18 Old 12-28-2010, 09:50 PM
Suzuki ATV Master!
 
zukifreak's Avatar
 
Join Date: Dec 2010
Location: DECIDING WHICH QUAD TO RIDE
Posts: 1,986
Resetting the codes i dont know,but i will see what can come up with.

If it dont work we will fix it while we have our dirty clothes on.Best experience is hands on experience.
IF IT AINT BROKE,DONT FIX IT.
zukifreak is offline  
post #7 of 18 Old 12-29-2010, 08:13 AM Thread Starter
Extreme ATV Enthusiast
 
liquid1's Avatar
 
Join Date: Dec 2010
Location: near charlotte nc
Posts: 407
Quote:
Originally Posted by zukifreak View Post
Resetting the codes i dont know,but i will see what can come up with.
When he turns on key a code of
C-15 = temper sensor
says check
FI light is on.. his sensor want be in for a few days.
He's tryin to find one sooner..

work hard to play hard.
Just picked me up a nice like new 07 450 Grizzly
Maybe a king 750 axi someday..
Give to my daughter 1998 honda 300FW 4x4 fourtrax
2002 ktm 520 exc dirt bike
http://www.youtube.com/watch?v=D9Gz6Y90Gas

Last edited by liquid1; 12-29-2010 at 08:16 AM.
liquid1 is offline  
post #8 of 18 Old 12-29-2010, 08:21 AM
Suzuki ATV Master!
 
zukifreak's Avatar
 
Join Date: Dec 2010
Location: DECIDING WHICH QUAD TO RIDE
Posts: 1,986
I havent found anything on clearing the codes,might want to check with a dealer.

If it dont work we will fix it while we have our dirty clothes on.Best experience is hands on experience.
IF IT AINT BROKE,DONT FIX IT.
zukifreak is offline  
post #9 of 18 Old 12-29-2010, 08:39 AM Thread Starter
Extreme ATV Enthusiast
 
liquid1's Avatar
 
Join Date: Dec 2010
Location: near charlotte nc
Posts: 407
Quote:
Originally Posted by zukifreak View Post
I havent found anything on clearing the codes,might want to check with a dealer.
Ok thanks, he's checking i'll post up the results and what fixes his scoot.

work hard to play hard.
Just picked me up a nice like new 07 450 Grizzly
Maybe a king 750 axi someday..
Give to my daughter 1998 honda 300FW 4x4 fourtrax
2002 ktm 520 exc dirt bike
http://www.youtube.com/watch?v=D9Gz6Y90Gas
liquid1 is offline  
post #10 of 18 Old 12-29-2010, 05:08 PM
Extreme ATV Enthusiast
 
Bojib's Avatar
 
Join Date: Oct 2010
Location: Chavies, KY
Posts: 186
I don't think these ATVs ever go into a Closed Loop setting, since there isn't any oxygen sensors like a car. I believe they run an open loop all the time.

The ECU basically just uses different maps according to input from pressure, throttle position, and temperature sensors, as well as engine RPM. I think anyway. I'm still learning ATV fuel injection.

2008 King Quad 450 AXi
-25" Maxxis Zillas
-Uni Air Filter
-NGK Iridium Plug
-Stanley FatMax Toolbox (used as storage box)
-Kolpin Fuel Pack Jr.
-Smittybilt 3000# Winch
-JTATV Coolant Gauge
Bojib is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Odometer Error????? IRONCURTAIN Repair and Maintenance 6 03-26-2013 08:06 AM
2007 Kingquad 700axi 4x4 atv bravo2 Suzuki KingQuad 19 02-20-2011 09:56 AM
Invite your friends zukifreak Site Issues & Suggestions 0 12-28-2010 08:15 PM
Welcome Friends! dascrow New Member Introductions 19 03-12-2009 02:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome