Suzuki King Quad 300 - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-01-2010, 12:59 PM Thread Starter
Suzuki ATVer
 
BLClemons's Avatar
 
Join Date: Jan 2010
Location: Tennessee
Posts: 2
Suzuki King Quad 300

Hello everyone,
I am having a problem out of my KQ300. So I went out to start it and it fired right up. Shortly after that 1 to 2 minutes it started smoking somewhere under the Tack/handlebar. I noticed what I think was a Rectifier was getting to hot and was melting the paint behind the frame. It was still running and I didnt want to tear up or start a fire so I turned it off. As soon as I started to turn it off it shut off by itself and wouldn't restart. I noticed a blow fuse so I replaced it and it started back up and ran normal until the rectifier overheated and the fuse melted and it shut down again. Where should I start in repairing this jewel. Thanks in advance for any help!
BLClemons is offline  
Advertisement
 
post #2 of 3 Old 01-02-2010, 11:57 AM Thread Starter
Suzuki ATVer
 
BLClemons's Avatar
 
Join Date: Jan 2010
Location: Tennessee
Posts: 2
Anyone have an idea why a rectifier would overheat?
BLClemons is offline  
post #3 of 3 Old 06-05-2010, 09:36 PM
ATV Enthusiast
 
rhinoexpress's Avatar
 
Join Date: Jun 2010
Location: Julian,PA
Posts: 95
I hate to say this, but sometimes they just go bad. I don't know why i would happen, but it sounds like you just need to replace it and of course check your wire harness for bare wires. It's a pretty rare case.
rhinoexpress is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
King Quad timing chain barny94 Repair and Maintenance 1 11-27-2013 10:05 AM
king quad 400 wiring up a winch??? 09King400 Performance Modifications 4 02-25-2012 03:01 PM
Suzuki 300 King Quad Problem framer__ Repair and Maintenance 2 12-16-2010 09:22 AM
1992 300 suzuki king quad wants to die hecklinhen Repair and Maintenance 5 10-09-2010 12:37 PM
King Quad 450 Swamped - 15 oil changes later... swamper Repair and Maintenance 0 06-02-2009 09:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome