suzuki eiger problem

This is a discussion on suzuki eiger problem within the Repair and Maintenance forums, part of the Suzuki ATV Technical Discussions category; My wife's 2005 Suzuki Eiger 400 fully automatic has a mechanical problem any help with this would be awsome. Ok here goes, the quad has ...

Go Back   Suzuki ATV Forum > Suzuki ATV Technical Discussions > Repair and Maintenance

Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.



Reply
 
LinkBack Thread Tools Display Modes
Old 11-24-2009, 03:18 PM   #1
New around here!
 
gr8renegadex's Avatar
 
Join Date: Nov 2009
Member #408
Posts: 1
View gr8renegadex's Photo Gallery()
suzuki eiger problem

My wife's 2005 Suzuki Eiger 400 fully automatic has a mechanical problem any help with this would be awsome. Ok here goes,
the quad has been running great lately but last week a friend was riding it when all of a sudden it started to loos power and then it would not run unless the choke was on then it would not stay running at all, I pulled the air filter it was clean, I checked the fuel it had plenty, I pulled the spark plug and it was a little black but not fouled, the qud then started but it would not run under throttle it would bog and rev then bog and rev, I limped it home out of the woods. This problem happen once before about 2 years ago and a local shop fixed it but they are no longer there so I have no Idea what they did, I will pull the carb this weekend and clean but I have no idea what else it could be, any and all help with this problem would be helpfull
Thank you,
Dave
gr8renegadex is offline   Reply With Quote
Old 11-30-2009, 03:45 PM   #2
New around here!
 
coty flowers's Avatar
 
Join Date: Nov 2009
Location: eastman, georgia
Member #420
Posts: 10
View coty flowers's Photo Gallery()
thats either your jet or your idle screw on the side of the carb i have the same model mine has done that before we took off the carb and come to find out it was my idle cord was turning some how wen i rev it up and my intake was opening and closing by itself but most likely its your carb check your jet and idle screws
coty flowers is offline   Reply With Quote
Reply


Search tags for this page

2003 suzuki eiger 400 problems

,
2005 suzuki eiger 400 problems
,
2005 suzuki eiger problems
,
Suzuki Eiger 400 Problems
,
Suzuki Eiger shifting problems
,

suzuki eiger 400 troubleshooting

,
suzuki eiger carburetor problems
,

suzuki eiger forum

,

suzuki eiger problems

,

suzuki eiger troubleshooting

,
suzuki eiger wont idle
,
suzuki eiger wont rev
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suzuki eiger 400 heeeeeeeeelp garywayne2u Repair and Maintenance 7 10-15-2011 08:32 PM
1992 Suzuki Quadrunner Lt F250 ATV Neutral Problem HELP!!!!!!! poundsjustice Repair and Maintenance 8 07-08-2010 09:43 PM
2005 Suzuki Eiger 400 4x4 Manuel Country Boy Wheels & Tires 1 12-29-2009 09:12 AM
Suzuki 454 single 4stroke single ignition problem davidhills Repair and Maintenance 3 11-07-2009 11:28 AM
2003 Suzuki eiger 400 4x4 clutch adjustment Eagle Repair and Maintenance 0 07-15-2009 11:59 AM

» Discount Tire
Motosport.com

Powered by vBadvanced CMPS v3.2.2
All times are GMT -6. The time now is 10:51 PM.
Looking for information on other ATV Manufacturers? Head on over to visit our friends on these other forums specializing in the following:
Kawasaki ATV - Can-Am ATV - Polaris ATV - Suzuki ATV - Yamaha ATV - Honda ATV

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.