05 Kingquad starts but backfires or shuts off.

This is a discussion on 05 Kingquad starts but backfires or shuts off. within the Repair and Maintenance forums, part of the Suzuki ATV Technical Discussions category; I have a 2005 Kingquad 700 that I let my brother borrow so he could go riding with his friends and when I got it ...

Go Back   Suzuki ATV Forum > Suzuki ATV Technical Discussions > Repair and Maintenance

Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.



Reply
 
LinkBack Thread Tools Display Modes
Old 10-06-2013, 04:07 PM   #1
Suzuki ATVer
 
Auss10's Avatar
 
Join Date: Oct 2013
Member #7280
Posts: 3
View Auss10's Photo Gallery()
05 Kingquad starts but backfires or shuts off.

I have a 2005 Kingquad 700 that I let my brother borrow so he could go riding with his friends and when I got it back it would barely crank. So I replaced the spark plug and put fresh gas in it. It will crank better now but when it cranks and I hit the gas after it idles for a while it sometimes shuts off or sometimes it will rev but when it does rev it starts back firing out of the exhaust and/or the intake. It does the same thing when I put it in gear and it will barely move. somebody said it could be the throttle position switch Any idea what it could be? and how I can fix it?
Auss10 is offline   Reply With Quote
Old 10-06-2013, 06:05 PM   #2
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Member #514
Posts: 4,734
View ajl719's Photo Gallery() Send a message via Yahoo to ajl719
I'm not very familiar with the newer style King Quads, so my knowledge about them is very limited. But, it could be anything from a computer issue, fuel injector, or throttle positioning sensor, etc. There is a video however on adjusting the throttle positioning sensor from our forum member Tubbytubb. Maybe check that out and see what you can come up with. And welcome to the forum.

( Adjusting TPS(Throttle Position Sensor On Fuel Injected King Quad )
__________________
2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
12,000 + km/s
ajl719 is offline   Reply With Quote
Old 10-06-2013, 08:06 PM   #3
Suzuki ATVer
 
Auss10's Avatar
 
Join Date: Oct 2013
Member #7280
Posts: 3
View Auss10's Photo Gallery()
thanks for the info! I will be sure to check it out
Auss10 is offline   Reply With Quote
Old 10-15-2013, 12:39 PM   #4
Suzuki ATVer
 
Auss10's Avatar
 
Join Date: Oct 2013
Member #7280
Posts: 3
View Auss10's Photo Gallery()
Well I adjusted the TPS sensor to the correct position and still does the same thing I think. I think it may be the ecu but not for sure. Any way I could tell? I know its getting fuel while its at idle but when I hit the throttle it doesn't get any more fuel.
Auss10 is offline   Reply With Quote
Old 10-16-2013, 02:27 PM   #5
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Member #514
Posts: 4,734
View ajl719's Photo Gallery() Send a message via Yahoo to ajl719
Could be the ECU or a bad fuel injector. It's hard to say since the new atv's are all pretty much computerized. And without proper equipment to read what the computer is reading/doing it's hard to say.
__________________
2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
12,000 + km/s
ajl719 is offline   Reply With Quote
Reply


Search tags for this page

2005 suzuki 700 king quad shutting off and hard to start

,
2005 suzuki king quad 700 spark plug
,

how to replace crankcase sensor on king quad 450

,

how to tell that a throttle position sensor is bad on a 05 700 suzuki king quad atv

,
king quad 700 spark plug
,
my quad backfires and shuts off
,

suzuki king quad 300 backfiring

,
suzuki king quad 700 back fire
,
suzuki king quad 700 spark plug location
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quad runner shuts off 1943mb Repair and Maintenance 10 08-27-2013 05:15 AM
750 King quad shuts off after about 10 min fallenangel Repair and Maintenance 12 01-04-2013 07:32 PM
2002 eiger auto trans shuts off in forward lobo Repair and Maintenance 0 09-11-2011 09:16 PM
suzuki 300 kingquad starts but wont rev bustedzook Repair and Maintenance 2 04-28-2011 08:43 PM
kingquad 450 09 no power after few minutes backfires and staals Simoniz Repair and Maintenance 10 02-24-2011 11:19 PM

» Discount Tire
Motosport.com

Powered by vBadvanced CMPS v3.2.2
All times are GMT -6. The time now is 12:49 PM.
Looking for information on other ATV Manufacturers? Head on over to visit our friends on these other forums specializing in the following:
Kawasaki ATV - Can-Am ATV - Polaris ATV - Suzuki ATV - Yamaha ATV - Honda ATV

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.