1983 quadrunner - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 08-08-2012, 08:18 PM Thread Starter
Suzuki ATVer
 
WillyB's Avatar
 
Join Date: Aug 2012
Posts: 4
1983 quadrunner

Just purchased a quadrunner. It will start fine. When put into first it won't go and sometimes dies. When I do get it going, it doesn't have much power and when down shifting it will stall out. Any ideas? Thanks
WillyB is offline  
Advertisement
 
post #2 of 7 Old 08-08-2012, 08:22 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 6,183
Send a message via Yahoo to ajl719
Sounds like the fuel petcock may be going bad. Could also be a dirty carb, but the stalling sounds very similar to what i was experiencing with my quad and this for me was the fuel petcock. And when you say the quad won't go sometimes when in first, do you mean it won't go because it has no power or just doesn't feel like the gear is engaged..? If it feels like it isn't engaging then the you may just need to adjust the clutch. And welcome to the forum.

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
13,000 + km/s

Last edited by ajl719; 08-08-2012 at 08:37 PM.
ajl719 is offline  
post #3 of 7 Old 08-08-2012, 08:33 PM Thread Starter
Suzuki ATVer
 
WillyB's Avatar
 
Join Date: Aug 2012
Posts: 4
Thanks for the welcome! When I said that it won't go the gear is engaged because is surges forward a tiny bit, but it is as if it just can muster up the energy. I will take a look at the carb and jets to see if there is some sort of plug. I have to ask, what is a petcock? I am new at this.
WillyB is offline  
Advertisement
 
post #4 of 7 Old 08-08-2012, 08:46 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 6,183
Send a message via Yahoo to ajl719
This here is the fuel petcock:

Click the image to open in full size.

The fuel petcock can be the On/Off/Res type, or it can be the On/Pri/Res type. Though seeing you quad is a 83 i believe it is the On/Off/Res type. The fuel petcock is a diaphragm operated system and open and closes depending on if the engine is running or not. The diaphragms in the petcock are known to go bad and when this happens stalling and poor running of the quad usually occur. Mine got to the point where it wouldn't stay idling without throttle, had almost no power, and hesitated under throttle.

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
13,000 + km/s
ajl719 is offline  
post #5 of 7 Old 08-08-2012, 08:56 PM Thread Starter
Suzuki ATVer
 
WillyB's Avatar
 
Join Date: Aug 2012
Posts: 4
I could not find the petcock. Does every atv have one? There is a post primer and a direct line to the carb. Am I retarded or am I looking for something that is not there?
WillyB is offline  
post #6 of 7 Old 08-08-2012, 09:06 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 6,183
Send a message via Yahoo to ajl719
No, seeing your atv is a very old model it is quite possible that it doesn't have one seeing you have a primer. If you would have a petcock it would be located under the fuel tank. If you still can't find it then you probably don't have one, in this case your problem probably lays in the carburetor.

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
13,000 + km/s

Last edited by ajl719; 08-08-2012 at 09:09 PM.
ajl719 is offline  
post #7 of 7 Old 08-08-2012, 09:08 PM Thread Starter
Suzuki ATVer
 
WillyB's Avatar
 
Join Date: Aug 2012
Posts: 4
Thanks for all of your help. I will clean that thing tomorrow. Have a great evening.
WillyB is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
need help with my 1983 lt 125??? ivan-ator Performance Modifications 27 03-17-2015 09:28 PM
1983 Suzuki LT 125 won't start dustin033 Repair and Maintenance 12 05-19-2013 01:00 PM
1983 LT 125 wont start Brad Ferguson Repair and Maintenance 9 12-14-2011 07:25 PM
hi what oil do i use in my 1983 lt 125 ivan-ator Repair and Maintenance 4 12-16-2010 08:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome