KQ 300 - weak fuel pump? - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-20-2011, 04:28 PM Thread Starter
Extreme ATV Enthusiast
 
EastCoastWest's Avatar
 
Join Date: May 2011
Location: Da ROCK!
Posts: 363
KQ 300 - weak fuel pump?

When I'm crusing at trail speeds and the tank goes below half it'll loose it's gas sometimes, seems to happen more when I hit a rough patch of trail. The lower the gas gets in the tank, the more often it seems to happen. I was on my way home today (put on 174 km) and had an idea, I put the fuel valve into the reserve postion and it never missed a beat the rest of the way home. Is this normal or is my pump going or something?

2001 Suzuki King Quad 300, 12,200 km.
2007 Ski-Doo GTX 500SS, 21,000 km
EastCoastWest is offline  
Advertisement
 
post #2 of 5 Old 08-20-2011, 06:13 PM
Suzuki ATV Master!
 
zukifreak's Avatar
 
Join Date: Dec 2010
Location: DECIDING WHICH QUAD TO RIDE
Posts: 1,986
If its running good on reserve the fuel pump is fine.I would drain the tank,pull the petcock to check the screens on the pickup tubes,it may also be a bad petcock most are vaccum operated and are known to fail.

If it dont work we will fix it while we have our dirty clothes on.Best experience is hands on experience.
IF IT AINT BROKE,DONT FIX IT.
zukifreak is offline  
post #3 of 5 Old 08-22-2011, 07:35 AM Thread Starter
Extreme ATV Enthusiast
 
EastCoastWest's Avatar
 
Join Date: May 2011
Location: Da ROCK!
Posts: 363
Mine is the vaccum operated version (two hoses going to it), I checked the online microfiche and there are two parts listed (44300-19B22 & 44300-19B30) with no way to tell which is which. I've encountered this situation with Suzuki fiche before, kind of confusing. We get hosed pretty good on parts up here so I usually order smaller stuff like that from the US but it doesn't help when I have no way to tell which is the correct part number.... /rant.

Two more questions:
What seals the petcock to the tank?
Do you think this problem wil get progressively worse or can I get away with running it on reserve for a while?

I just spent $150 to make and install a full length 3/8" teflon skid plate because the steel ones were trashed.

2001 Suzuki King Quad 300, 12,200 km.
2007 Ski-Doo GTX 500SS, 21,000 km
EastCoastWest is offline  
Advertisement
 
post #4 of 5 Old 08-22-2011, 10:14 AM
Suzuki ATV Master!
 
zukifreak's Avatar
 
Join Date: Dec 2010
Location: DECIDING WHICH QUAD TO RIDE
Posts: 1,986
You can continue to run on reserve.

If it dont work we will fix it while we have our dirty clothes on.Best experience is hands on experience.
IF IT AINT BROKE,DONT FIX IT.
zukifreak is offline  
post #5 of 5 Old 08-23-2011, 07:18 AM Thread Starter
Extreme ATV Enthusiast
 
EastCoastWest's Avatar
 
Join Date: May 2011
Location: Da ROCK!
Posts: 363
Thanks.

2001 Suzuki King Quad 300, 12,200 km.
2007 Ski-Doo GTX 500SS, 21,000 km
EastCoastWest is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pump & carburetor hoses HC1968 Repair and Maintenance 1 07-06-2011 09:39 AM
question on fuel pump flow rate dsmith222 Repair and Maintenance 1 05-25-2011 11:30 PM
Fuel pump question Fastrax Repair and Maintenance 6 01-15-2011 09:54 AM
85 LT 125 fuel pump issue WFOWS6_IL Repair and Maintenance 3 11-26-2010 06:47 PM
fuel pump 700 king harleyjb01 Repair and Maintenance 0 12-18-2009 06:36 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome