electric start - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 04-29-2011, 10:18 PM Thread Starter
Suzuki ATVer
 
True North's Avatar
 
Join Date: Apr 2011
Posts: 1
electric start

1999 or 2000 LTF 500 key on, neutral light on, will not start, pull start works, eletric start work sporadically. It runs great. Help
True North is offline  
Advertisement
 
post #2 of 4 Old 04-30-2011, 12:38 PM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 6,183
Send a message via Yahoo to ajl719
Check the connections at the starter and make sure they are clean and that you have no loose connections. If your starter is working sporadically it may be a sign it's going on the fritz. If so you'll need to purchase a new starter. But check the connections first and go from there.

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
13,000 + km/s

Last edited by ajl719; 04-30-2011 at 12:43 PM.
ajl719 is offline  
post #3 of 4 Old 04-30-2011, 08:59 PM
Super Moderator
 
TUBBYTUBB's Avatar
 
Join Date: Sep 2010
Location: Louisiana Boy Living in Central Western Illinois..
Posts: 2,938
Send a message via Yahoo to TUBBYTUBB
Does it sound like the starter is dragging, if so it could possibly be the one-way starter clutch going out.



THOMAS

The One and Only TUBBYTUBB

Click the image to open in full size.
1997 King Quad 300 Still Alive and Kicking Just Giving It A Rest
As In Life: Always Try The Simplest Things First Then Move On to The Bigger Things To Fix The Problems In Front Of You - TUBBYTUBB
TUBBYTUBB is offline  
Advertisement
 
post #4 of 4 Old 05-05-2011, 12:53 AM
Suzuki ATVer
 
mrmongoman's Avatar
 
Join Date: Apr 2011
Posts: 7
I flipped mine in the mud and got the switches on the bars full of dirt and nothing there would work. might be dirt in your push button
mrmongoman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1986 Electric Start Problem AGDrake57 Repair and Maintenance 2 04-28-2010 12:44 PM
250 Electric start iRace Repair and Maintenance 1 09-22-2009 08:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome