Suzuki LT-F4WDX Electrical Problem - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-17-2010, 11:47 AM Thread Starter
Suzuki ATVer
 
eitok's Avatar
 
Join Date: Oct 2010
Posts: 1
Suzuki LT-F4WDX Electrical Problem

All - I have a problem that has had me scratching my head all day long. This is whats happening. I can start my quad up just fine, but when I let go of the start button, it immediately dies. Even more interesting is, if I disconnect the battery and start it with the pull rope it will start and run just fine. If while it is running I reconnect the battery it immediately dies... Euh! I will spare you all the different test I have done so you all can go at this with an open mind. I have worked around automotive electrical systems for years and this one has me stumped. Thanks for any help you can provide!
eitok is offline  
Advertisement
 
post #2 of 2 Old 12-15-2010, 10:45 PM
Suzuki ATV Master!
 
zukifreak's Avatar
 
Join Date: Dec 2010
Location: DECIDING WHICH QUAD TO RIDE
Posts: 1,986
Check your rectifier,sounds like its bad.
zukifreak is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
99 King Quad electrical problem MarcoBolo Repair and Maintenance 9 06-02-2011 12:28 AM
Problem with 2004 Suzuki Eiger 400 PA452 ATV General Discussion 7 12-16-2010 11:10 AM
1991 Suzuki 250 lt-f carb problem Gasoo Performance Modifications 0 06-11-2010 11:37 AM
1997 suzuki king quad 300 LT-F4WDX oproy767 Repair and Maintenance 0 05-02-2010 10:47 AM
suzuki eiger problem gr8renegadex Repair and Maintenance 1 11-30-2009 02:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome