Eiger 400 starting trouble - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 06-08-2009, 02:29 PM Thread Starter
Suzuki ATVer
 
BiggT's Avatar
 
Join Date: Jun 2009
Posts: 2
Smile Eiger 400 starting trouble

I have a 2004 Eiger 400. This machine has always been reliable and trustworthy. Lately it takes an act of god to start it. Turns over, pops, pops, pops some more and then eventually fires. I have emptied and changed the gas and the plug. Added carb cleaner. Removed, disassembled the carb, blown it out, re-assembled with same problem. When it gets running it runs great. No issues while its running. It may stall once or twice till it warms up. Even after riding it, if you shut it down it starts hard. Any thoughts?? Your help is appreciated.
BiggT is offline  
Advertisement
 
post #2 of 3 Old 06-09-2009, 02:44 PM
Extreme ATV Enthusiast
 
LTZ400rider's Avatar
 
Join Date: Jan 2009
Posts: 137
The starter?

2003 LT-Z400
-Team Zuki/Yoshimura Exhaust
-Suzuki nerfs with heelguards
-Suzuki A-arm guards
-Blingstar Iron Cross bumper
-UNI


I am Jbacon on Honda Atv forums...
LTZ400rider is offline  
post #3 of 3 Old 06-10-2009, 01:57 AM
Suzuki ATVer
 
beart0y's Avatar
 
Join Date: Jun 2009
Posts: 13
Fuel contaminated with alcohol? Poor spark? Whats the compression?
beart0y is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Suzuki Eiger 400 4x4 Manuel Country Boy Wheels & Tires 1 12-29-2009 08:12 AM
Suzuki jr 50cc not starting, vacuum line LittleSpark Repair and Maintenance 1 05-19-2009 07:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome