Vinson auto. clutch hanging and noise - Suzuki ATV Forum
Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-22-2010, 01:36 PM Thread Starter
Suzuki ATVer
 
Tyler's Avatar
 
Join Date: Jun 2010
Posts: 1
Vinson auto. clutch hanging and noise

Hey guys,I just installed another motor in my 02 Vinson Auto. and am having problems with the clutch not releasing when I come to a stop, it will keep chugging along at idle. Also get alot of chatter from the clutch cover area. So far I have tried both the primary and secondary clutches from the old motor which were working fine, I have tried the old belt, I have removed the wet clutch and inpected it and it looks fine. Any suggestion? anyone else ever come accross this problem? Thanks
Tyler is offline  
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Suzuki vinson 500 semi auto Babyrach ATV General Discussion 9 02-17-2012 05:00 PM
Ozark engine noise ozarkman Suzuki Ozark 1 09-25-2011 11:20 AM
eiger 400 4x4 auto holmes8885@yahoo.com Repair and Maintenance 0 03-10-2010 08:32 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome