2004 twin peaks 700 problem

This is a discussion on 2004 twin peaks 700 problem within the Repair and Maintenance forums, part of the Suzuki ATV Technical Discussions category; when riding today, i noticed that the transmission was making alot of noise when it was shifting between 2wd and 4wd. there was a connector ...

Go Back   Suzuki ATV Forum > Suzuki ATV Technical Discussions > Repair and Maintenance

Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.



Reply
 
LinkBack Thread Tools Display Modes
Old 04-19-2010, 05:37 PM   #1
New around here!
 
kylemdotcom's Avatar
 
Join Date: Apr 2010
Member #703
Posts: 1
View kylemdotcom's Photo Gallery()
2004 twin peaks 700 problem

when riding today, i noticed that the transmission was making alot of noise when it was shifting between 2wd and 4wd. there was a connector by the unit making the noise so i disconnected it to see if it would stop making noise. it didnt. it actually created a new problem. it now wont go over 12 mph and backfires once you try to go faster. i plugged that connector back up and still doing the same thing. i disconnected the battery and still does it. any ideas on how fix my F*&% up?
kylemdotcom is offline   Reply With Quote
Old 09-27-2012, 12:05 PM   #2
Suzuki ATVer
 
rocko13's Avatar
 
Join Date: Sep 2012
Member #5333
Posts: 4
View rocko13's Photo Gallery()
My 700 is also doing the same thing and I am having trouble finding a repair facility that can diagnose this. Have had the atv at 2 repair facilitys neither has a solid idea of what is causing this. One says its the actuator the other thinks it may be a limiter switch???? This happened after a belt went bad with chunks of it missing for some reason.

Last edited by rocko13; 10-01-2012 at 09:02 PM. Reason: more info
rocko13 is offline   Reply With Quote
Reply


Search tags for this page

2004 suzuki twin peaks belt light

,
2004 suzuki twin peaks belt reset
,

2004suzukitwinpeaksbeltlight

,
suzuki 700 twin peaks belt light
,
suzuki 700 twin peaks belt light reset
,

suzuki twin peaks 700 belt light

,

suzuki twin peaks 700 belt light reset

,
suzuki twin peaks 700 problems
,

suzuki twin peaks belt light

,

suzuki twin peaks belt light reset

,
suzuki twin peaks forum
,
suzuki twin peaks problems
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Vinson 500 Limited Part Out cams ATV Parts for Sale 10 02-09-2013 04:33 PM
2004 Quad sport oiling question old 300 Suzuki QuadSport 0 04-05-2010 06:45 PM
2004 Quad Sport 80 driveline maintainence old 300 Suzuki QuadSport 0 04-02-2010 06:31 PM
Backfiring 2004 Twin Peaks 700 colvja New Member Introductions 4 01-25-2009 01:00 PM

» Discount Tire
Motosport.com

Powered by vBadvanced CMPS v3.2.2
All times are GMT -6. The time now is 03:14 PM.
Looking for information on other ATV Manufacturers? Head on over to visit our friends on these other forums specializing in the following:
Kawasaki ATV - Can-Am ATV - Polaris ATV - Suzuki ATV - Yamaha ATV - Honda ATV

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.