need help with my 1983 lt 125??? - Page 3 - Suzuki ATV Forum
Performance Modifications Have Modifications? Want to ask about a mod? Having problems with a certain mod? Ask and post here! Carbs, Exhausts, Engines, Etc...

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 28 Old 01-23-2011, 12:54 AM Thread Starter
ATV Enthusiast
 
ivan-ator's Avatar
 
Join Date: Nov 2010
Location: CA
Posts: 33
yea its all in good time..
ivan-ator is offline  
Advertisement
 
post #22 of 28 Old 03-16-2011, 10:22 AM
Suzuki ATVer
 
jrharley's Avatar
 
Join Date: Jan 2011
Location: Keithville
Posts: 20
Sorry for posting twice I didnt know that happened, lol, thanls for all the help guys, I never thought about cleaning the fuel petcock, can someone give me a number that I could use to get the air filter, not a phone number, the filter number. THANKS AGAIN
jrharley is offline  
post #23 of 28 Old 03-16-2011, 11:54 AM
Super Moderator
 
ajl719's Avatar
 
Join Date: Jan 2010
Location: Iroquois Falls On, Canada
Posts: 6,139
Send a message via Yahoo to ajl719
For what type of atv are you looking for a filter..?

2000 Suzuki King Quad 300 4x4
K&N Air Filter
2300 lbs Superwinch
Kenda Bear Claws (Rear 25X10-12) - (Front 24X9-11)
Differential Lock Mod
13,000 + km/s
ajl719 is online now  
Advertisement
 
post #24 of 28 Old 03-17-2011, 03:39 PM
Suzuki ATVer
 
jrharley's Avatar
 
Join Date: Jan 2011
Location: Keithville
Posts: 20
1983 suzuki lt 125
jrharley is offline  
post #25 of 28 Old 03-17-2011, 06:53 PM
Super Moderator
 
TUBBYTUBB's Avatar
 
Join Date: Sep 2010
Location: Louisiana Boy Living in Central Western Illinois..
Posts: 2,938
Send a message via Yahoo to TUBBYTUBB
K & N Oil Filter | Rocky Mountain ATV/MC

There you go.



THOMAS

The One and Only TUBBYTUBB

Click the image to open in full size.
1997 King Quad 300 Still Alive and Kicking Just Giving It A Rest
As In Life: Always Try The Simplest Things First Then Move On to The Bigger Things To Fix The Problems In Front Of You - TUBBYTUBB
TUBBYTUBB is offline  
post #26 of 28 Old 04-27-2011, 10:32 AM
Suzuki ATVer
 
jrharley's Avatar
 
Join Date: Jan 2011
Location: Keithville
Posts: 20
Thanks for the link, I bought it and put it on, and it doesnt change anything. I can get it to start, but it has absolutly no power, I can floor it and it just boggs. Some one told me it might be the CDI unit. Is that possible?
jrharley is offline  
post #27 of 28 Old 04-28-2011, 12:29 PM
420
Suzuki ATVer
 
420's Avatar
 
Join Date: Apr 2011
Location: new phila
Posts: 1
lt 125

check valves in top end of motor.
420 is offline  
post #28 of 28 Old 03-17-2015, 09:28 PM
Suzuki ATVer
 
chaley339's Avatar
 
Join Date: Mar 2015
Posts: 1
what's an update on this???

Just wondering if this issue was ever resolved
chaley339 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome